aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby20
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-02-02 07:19:51 +0800
committerbapt <bapt@FreeBSD.org>2015-02-02 07:19:51 +0800
commita3e218a0cacef39f99533f7cf9bbd80e65d54c88 (patch)
tree99f59761056f1c7f2c9dd59918617fc3afe7a8e0 /lang/ruby20
parent56f389260e69b32aef926c764db25b2412ef5fae (diff)
downloadfreebsd-ports-gnome-a3e218a0cacef39f99533f7cf9bbd80e65d54c88.tar.gz
freebsd-ports-gnome-a3e218a0cacef39f99533f7cf9bbd80e65d54c88.tar.zst
freebsd-ports-gnome-a3e218a0cacef39f99533f7cf9bbd80e65d54c88.zip
Change the EDIT option of ruby to use libedit by default now that libedit
from ports is able to handle unicode. Make sure that ruby does not provides its own function to read the input but let libedit do it itself. This allows the binary package to by default not be "tainted" by the readline license. Differential Revision: https://reviews.freebsd.org/D1547 Reviewed by: swills Approved by: ruby (swills)
Diffstat (limited to 'lang/ruby20')
-rw-r--r--lang/ruby20/Makefile2
-rw-r--r--lang/ruby20/files/patch-ext_readline_extconf.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index 35b490096282..b537d49f617a 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -49,7 +49,7 @@ RUBY_NO_RUN_DEPENDS= yes
NO_LATEST_LINK= yes
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES RDOC
-OPTIONS_DEFAULT= RDOC READLINE
+OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT
OPTIONS_SINGLE_EDIT= LIBEDIT READLINE
OPTIONS_SUB= yes
diff --git a/lang/ruby20/files/patch-ext_readline_extconf.rb b/lang/ruby20/files/patch-ext_readline_extconf.rb
new file mode 100644
index 000000000000..1dc60bf099c3
--- /dev/null
+++ b/lang/ruby20/files/patch-ext_readline_extconf.rb
@@ -0,0 +1,11 @@
+--- ext/readline/extconf.rb.orig 2014-04-30 07:39:45 UTC
++++ ext/readline/extconf.rb
+@@ -62,7 +62,7 @@ else
+ end
+
+ readline.have_func("rl_getc")
+-readline.have_func("rl_getc_function")
++#readline.have_func("rl_getc_function")
+ readline.have_func("rl_filename_completion_function")
+ readline.have_func("rl_username_completion_function")
+ readline.have_func("rl_completion_matches")