aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby20
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-09-14 23:53:45 +0800
committerswills <swills@FreeBSD.org>2014-09-14 23:53:45 +0800
commit17f59e20218d21439e38c55d43f5458567e09541 (patch)
tree7d7e169f574bab104d5163446c2e3f0eb25adbae /lang/ruby20
parentbb7d297b9e46c1c78528e8607ecfa580f018c5d0 (diff)
downloadfreebsd-ports-gnome-17f59e20218d21439e38c55d43f5458567e09541.tar.gz
freebsd-ports-gnome-17f59e20218d21439e38c55d43f5458567e09541.tar.zst
freebsd-ports-gnome-17f59e20218d21439e38c55d43f5458567e09541.zip
lang/ruby20: switch to USES=execinfo
While here, move MAKE_JOBS_UNSAFE to CAPIDOCS option since thats the only place it seems necessary PR: 193412 Submitted by: Yasuhiro KIMURA <yasu@utahime.org>
Diffstat (limited to 'lang/ruby20')
-rw-r--r--lang/ruby20/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index 512972a87ff1..68269a190843 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -17,8 +17,7 @@ COMMENT?= Object-oriented interpreted scripting language
LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libyaml.so:${PORTSDIR}/textproc/libyaml
+LIB_DEPENDS= libyaml.so:${PORTSDIR}/textproc/libyaml
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
@@ -47,8 +46,6 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
-MAKE_JOBS_UNSAFE= yes
-
NO_LATEST_LINK= yes
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES RDOC
@@ -66,7 +63,7 @@ CAPIDOCS_BUILD_DEPENDS= doxygen>0:${PORTSDIR}/devel/doxygen \
CAPIDOCS_CONFIGURE_OFF= --disable-install-capi
RDOC_CONFIGURE_OFF= --disable-install-rdoc
-USES= tar:bzip2 cpe
+USES= execinfo cpe tar:bzip2
CPE_VENDOR= ruby-lang
CPE_VERSION= ${RUBY_RELVERSION}
@@ -94,6 +91,10 @@ CONFIGURE_ARGS+= --disable-dtrace
CONFIGURE_ENV= debugflags=
+.if ${PORT_OPTIONS:MCAPIDOCS}
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ${PORT_OPTIONS:MLIBEDIT}
BUILD_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit
RUN_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit