aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby22
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-25 20:58:33 +0800
committermarino <marino@FreeBSD.org>2015-03-25 20:58:33 +0800
commit5aae8d908d47fe8094dcc908ae88f162d9510445 (patch)
treeb03cfdc045d4887da1bbcf9872d0180f879152a5 /lang/ruby22
parentbaa54cb73c8e4707d00379321c09d674a081b29f (diff)
downloadfreebsd-ports-gnome-5aae8d908d47fe8094dcc908ae88f162d9510445.tar.gz
freebsd-ports-gnome-5aae8d908d47fe8094dcc908ae88f162d9510445.tar.zst
freebsd-ports-gnome-5aae8d908d47fe8094dcc908ae88f162d9510445.zip
lang category: Remove $PTHREAD_LIBS
Note: ecl did not pass check-plist (pre-existing), PR 198897 submitted. approved by: PTHREAD blanket
Diffstat (limited to 'lang/ruby22')
-rw-r--r--lang/ruby22/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index ba57e6772a6a..55f6ec165c55 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -82,7 +82,7 @@ _SUF1= _${PORTREVISION}
CPPFLAGS+= -I${LOCALBASE}/include
# Keep this, else ruby will fail to load libraries dependent op libpthread.
-LIBS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LIBS+= -lpthread -L${LOCALBASE}/lib
.if ${OPSYS} == "FreeBSD"
.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032)
@@ -132,7 +132,7 @@ RB_SET_CONF_VAR=${SH} -c '${REINPLACE_CMD} -E -e "s,(CONFIG\[\"$$0\"\][[:space:]
post-patch:
@${REINPLACE_CMD} -E \
- -e 's,-l$$pthread_lib,${PTHREAD_LIBS},g' \
+ -e 's,-l$$pthread_lib,-lpthread,g' \
-e '/^RUBY_LIB_PATH/s,\.\$$\{TEENY\},,' \
-e '/^RUBY_SITE_LIB_PATH2/s,\.\$$\{TEENY\},,' \
-e '/^RUBY_VENDOR_LIB_PATH2/s,\.\$$\{TEENY\},,' \