aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby22
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-07-12 05:03:09 +0800
committerswills <swills@FreeBSD.org>2017-07-12 05:03:09 +0800
commitf63f60b81886d5156c4e684c5c30d5cdc87f8d6b (patch)
tree94235cf860cac8f36d39f04bc16e5f5d252a4f99 /lang/ruby22
parent2383dcff2f507921ab81d28dd07a710c23e43a32 (diff)
downloadfreebsd-ports-gnome-f63f60b81886d5156c4e684c5c30d5cdc87f8d6b.tar.gz
freebsd-ports-gnome-f63f60b81886d5156c4e684c5c30d5cdc87f8d6b.tar.zst
freebsd-ports-gnome-f63f60b81886d5156c4e684c5c30d5cdc87f8d6b.zip
lang/ruby2{2,3,4}: require libunwind
Since ruby detects this if it's installed, and it's more often installed now due to other deps, and ruby provides no way to not depend on it if it's found, pull it in as a dependency unconditionally. While here, fix plist for ruby 2.4 with the CAPIDOCS option on, and restore the MAKE_JOBS_UNSAFE flag when using that build option since it's not fixed like I thought it was. PR: 219796 Reported by: Grzegorz Junka <list1@gjunka.com>
Diffstat (limited to 'lang/ruby22')
-rw-r--r--lang/ruby22/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index 4dabaaf8db86..e8565093b16b 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -93,6 +93,11 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
.endif
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == "amd64" || ${ARCH} == "i386")
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
.if ${ARCH} == "powerpc64"
USE_GCC= yes
.endif