aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby25/files
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2018-07-28 10:53:05 +0800
committerfluffy <fluffy@FreeBSD.org>2018-07-28 10:53:05 +0800
commit6838d9f1cf8104aba136ffbc14db9de198bffe64 (patch)
treee791029a9e756295a3668d303bfffcefd3ec1d7b /lang/ruby25/files
parent6d69c75bafeafb0c5e3e9bdedbf46b13d277df9e (diff)
downloadfreebsd-ports-gnome-6838d9f1cf8104aba136ffbc14db9de198bffe64.tar.gz
freebsd-ports-gnome-6838d9f1cf8104aba136ffbc14db9de198bffe64.tar.zst
freebsd-ports-gnome-6838d9f1cf8104aba136ffbc14db9de198bffe64.zip
lang/ruby2[4|5]: Use internal RUBY_DLDFLAGS right way, get rid of unescaped macro '$@' in the pkg-config template
lang/ruby23 is already fixed same way, port it to newer releases By the way, this unbreak ninja builds with any port relied on libruby.so PR: 229898 Submitted by: fluffy Reviewed by: ruby (miwi) Approved by: ruby (miwi) Exp-run by: antoine MFH: 2018Q3 Differential Revision: D16341
Diffstat (limited to 'lang/ruby25/files')
-rw-r--r--lang/ruby25/files/patch-configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/lang/ruby25/files/patch-configure.ac b/lang/ruby25/files/patch-configure.ac
new file mode 100644
index 000000000000..e16888525232
--- /dev/null
+++ b/lang/ruby25/files/patch-configure.ac
@@ -0,0 +1,19 @@
+--- configure.ac.orig 2018-01-04 02:12:16.000000000 +0800
++++ configure.ac 2018-07-19 14:45:11.636321000 +0800
+@@ -3245,7 +3245,6 @@
+ : ${LDSHARED='$(CC) -shared'}
+ AS_IF([test "$rb_cv_binary_elf" = yes], [
+ LDFLAGS="$LDFLAGS -rdynamic"
+- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
+ ], [
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
+ ])
+@@ -3724,6 +3723,8 @@
+ SOLIBS='$(LIBS)'
+ LIBRUBY_SO='lib$(RUBY_SO_NAME).$(SOEXT).$(MAJOR)$(MINOR)'
+ LIBRUBY_SONAME='$(LIBRUBY_SO)'
++ RUBY_APPEND_OPTIONS(DLDFLAGS, ['-Wl,-soname,${LIBRUBY_SO}' "$LDFLAGS_OPTDIR"])
++ RUBY_APPEND_OPTIONS(LIBRUBY_DLDFLAGS, ['-Wl,-soname,${LIBRUBY_SO}' "$LDFLAGS_OPTDIR"])
+ AS_IF([test "$rb_cv_binary_elf" != "yes" ], [
+ LIBRUBY_SO="$LIBRUBY_SO.\$(TEENY)"
+ LIBRUBY_ALIASES=''