aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2000-01-26 02:33:42 +0800
committersumikawa <sumikawa@FreeBSD.org>2000-01-26 02:33:42 +0800
commitf0a8e422e1e4591b7176d0b43220ad55ec839b78 (patch)
tree3b4fa9674d235f8fcb77ffe8f01c738524a30908 /lang/ruby
parenta9335e51df136062eb8b594fd2e6765454c4b6e3 (diff)
downloadfreebsd-ports-gnome-f0a8e422e1e4591b7176d0b43220ad55ec839b78.tar.gz
freebsd-ports-gnome-f0a8e422e1e4591b7176d0b43220ad55ec839b78.tar.zst
freebsd-ports-gnome-f0a8e422e1e4591b7176d0b43220ad55ec839b78.zip
Use ${OSVERSION} instead of ${USE_INET6}.
Reviewed by: maintainer
Diffstat (limited to 'lang/ruby')
-rw-r--r--lang/ruby/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 21b224037935..6b555d0e88ca 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -19,9 +19,6 @@ MAINTAINER= yasuf@big.or.jp
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-shared
-.if defined(USE_INET6)
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
MAN1= ruby.1
PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
@@ -33,6 +30,12 @@ BRANCH_NAME= 1.4
DOCDIR= ${PREFIX}/share/doc/ruby
EXAMPLESDIR= ${PREFIX}/share/examples/ruby
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 400014
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
post-patch:
${RM} -f ${WRKSRC}/ext/tcltklib/MANIFEST
${RM} -f ${WRKSRC}/ext/tk/MANIFEST
@@ -66,4 +69,4 @@ post-install:
test:
@(cd ${WRKSRC}; make test)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>