aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-04-02 05:21:27 +0800
committerknu <knu@FreeBSD.org>2001-04-02 05:21:27 +0800
commit54041b6d2898599e6e17fdeb396f23224a7f4d05 (patch)
tree69e38df13969493daaf67461100871ad58f4adec /lang/ruby
parentd7ffd174cec4baa9d28cb341fac71ab183a7c18c (diff)
downloadfreebsd-ports-gnome-54041b6d2898599e6e17fdeb396f23224a7f4d05.tar.gz
freebsd-ports-gnome-54041b6d2898599e6e17fdeb396f23224a7f4d05.tar.zst
freebsd-ports-gnome-54041b6d2898599e6e17fdeb396f23224a7f4d05.zip
Do a ${MV} with -f so that the installation process won't stop and ask
a question when some version of ruby is already installed. This is useful when you want to automatically upgrade the port using portupgrade. :) Submitted by: Jimmy Olgeni <olgeni@uli.it>
Diffstat (limited to 'lang/ruby')
-rw-r--r--lang/ruby/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 3cb73fb361e7..2de3aef69763 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -58,7 +58,7 @@ post-patch:
post-install:
strip ${RUBY}
.if empty(RUBY_SUFFIX)
- ${MV} ${RUBY} ${RUBY}${_RUBY_SUFFIX}
+ ${MV} -f ${RUBY} ${RUBY}${_RUBY_SUFFIX}
${LN} -fs ${RUBY}${_RUBY_SUFFIX} ${RUBY}
${MV} ${PREFIX}/man/man1/ruby.1 ${PREFIX}/man/man1/ruby${_RUBY_SUFFIX}.1
.else