aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rust
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-04-07 15:17:45 +0800
committerjbeich <jbeich@FreeBSD.org>2016-04-07 15:17:45 +0800
commit6a567bf01a4b5ce1d14324c3d0b741c6fa32b9b6 (patch)
treefa9b622245e09a9f2f006324cfd1ad68a41cb293 /lang/rust
parent28e9c1887af3ab1cd5c03b63a517680ad2d68b7a (diff)
downloadfreebsd-ports-gnome-6a567bf01a4b5ce1d14324c3d0b741c6fa32b9b6.tar.gz
freebsd-ports-gnome-6a567bf01a4b5ce1d14324c3d0b741c6fa32b9b6.tar.zst
freebsd-ports-gnome-6a567bf01a4b5ce1d14324c3d0b741c6fa32b9b6.zip
lang/rust: unbreak non-poudriere build after r412305
gmake[1]: Leaving directory '/wrkdirs/usr/ports/lang/rust/work/rustc-1.7.0' sed: /wrkdirs/usr/ports/lang/rust/work/stage/usr/local/lib/rustlib/manifest-rust-std-x86_64-unknown-: No such file or directory *** Error code 1 PR: 208527 Pointy hat: jbeich Tested by: Marko Cupać <marko.cupac@mimar.rs>, pilot513@gmail.com Approved by: riggs (maintainer) MFH: 2016Q2
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index a30717756eee..b29468ea7877 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -125,13 +125,13 @@ post-patch:
# new ones. Otherwise, the staging directory is polluted with unneeded
# files.
pre-install:
-.for f in manifest-rustc manifest-rust-std-${RUST_TARGET}
- @if test -f ${STAGEDIR}${PREFIX}/lib/rustlib/${f}; then \
+ @for f in manifest-rustc manifest-rust-std-${RUST_TARGET}; do \
+ if test -f ${STAGEDIR}${PREFIX}/lib/rustlib/$$f; then \
${SED} -E -e 's,^(dir|file:),${STAGEDIR},' \
- < ${STAGEDIR}${PREFIX}/lib/rustlib/${f} \
+ < ${STAGEDIR}${PREFIX}/lib/rustlib/$$f \
| ${XARGS} ${RM}; \
- fi
-.endfor
+ fi; \
+ done
@${RM} \
${STAGEDIR}${PREFIX}/lib/rustlib/components \
${STAGEDIR}${PREFIX}/lib/rustlib/manifest-rustc \
@@ -140,11 +140,11 @@ pre-install:
${STAGEDIR}${PREFIX}/lib/rustlib/uninstall.sh
post-install:
-.for f in manifest-rustc manifest-rust-std-${RUST_TARGET}
- @${REINPLACE_CMD} -e 's|${STAGEDIR}||' \
- ${STAGEDIR}${PREFIX}/lib/rustlib/${f}
- @${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/${f}.bak
-.endfor
+ @for f in manifest-rustc manifest-rust-std-${RUST_TARGET}; do \
+ ${REINPLACE_CMD} -e 's|${STAGEDIR}||' \
+ ${STAGEDIR}${PREFIX}/lib/rustlib/$$f; \
+ ${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/$$f.bak; \
+ done
@${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/install.log
# FIXME: Static libraries in lib/rustlib/*/lib/*.rlib are not stripped,
# but they contain non-object files which make strip(1) unhappy.