aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rust
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-21 03:32:39 +0800
committertijl <tijl@FreeBSD.org>2014-05-21 03:32:39 +0800
commitb30a0528adcb5402b2b782818bfbacc30e522a2f (patch)
tree2ae9e1593b29ed28637a9cbae361c9e3af678802 /lang/rust
parentec0617588a58221b0f33e8f668acb551394883e6 (diff)
downloadfreebsd-ports-gnome-b30a0528adcb5402b2b782818bfbacc30e522a2f.tar.gz
freebsd-ports-gnome-b30a0528adcb5402b2b782818bfbacc30e522a2f.tar.zst
freebsd-ports-gnome-b30a0528adcb5402b2b782818bfbacc30e522a2f.zip
Quote ${CC} and similar variables in MAKE_ARGS.
Reported by: Dominic Fandrey <kamikaze@bsdforen.de>
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index acfe3fe4446f..2d6603e81dc3 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -57,7 +57,7 @@ CC= clang
CXX= clang++
CONFIGURE_ARGS+= --disable-valgrind --disable-docs \
--enable-clang --mandir=${MANPREFIX}/man
-MAKE_ARGS+= CC=${CC} CXX=${CXX} ARCH=x86_64
+MAKE_ARGS+= CC="${CC}" CXX="${CXX}" ARCH=x86_64
post-extract:
${MKDIR} ${WRKSRC}/${RUST_TARGET} && \