aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rust
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2018-03-22 00:20:51 +0800
committerbdrewery <bdrewery@FreeBSD.org>2018-03-22 00:20:51 +0800
commitb1e6dedfcd2b2a431597f3dc70748ba7af789521 (patch)
treef5523cbf1588b1f9a15b2a8b4ac5d6147a05f7ed /lang/rust
parent84014c87d91898ff958e474a1207e179998b7259 (diff)
downloadfreebsd-ports-gnome-b1e6dedfcd2b2a431597f3dc70748ba7af789521.tar.gz
freebsd-ports-gnome-b1e6dedfcd2b2a431597f3dc70748ba7af789521.tar.zst
freebsd-ports-gnome-b1e6dedfcd2b2a431597f3dc70748ba7af789521.zip
Update rust-nightly to 2018-03-21.
The ABI patch and bootstrap patching are no longer needed on head after fixes fully upstreamed in https://github.com/rust-lang/rust/issues/42681.
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 5a326a10b14e..0ad51507b1bb 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -92,8 +92,13 @@ PLIST_FILES= lib/rustlib/components \
lib/rustlib/rust-installer-version
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200031
+# ABI patch needed to address ino64 before fixes upstreamed.
+# https://github.com/rust-lang/rust/issues/42681
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200031 && !defined(NIGHTLY_DATE)
+NEED_ABI_PATCH= 1
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-abi
+.else
+NEED_ABI_PATCH= 0
.endif
X_PY_ENV= HOME="${WRKDIR}" \
@@ -135,13 +140,13 @@ post-extract:
${WRKSRC}/build/cache/${BOOTSTRAPS_DATE_${ARCH}:U${BOOTSTRAPS_DATE}}
${LN} -sf ${DISTDIR}/${DIST_SUBDIR}/${RUSTC_BOOTSTRAP} \
${WRKSRC}/build/cache/${BOOTSTRAPS_DATE_${ARCH}:U${BOOTSTRAPS_DATE}}
-.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1200031
+.if ${NEED_ABI_PATCH} == 0
${LN} -sf ${DISTDIR}/${DIST_SUBDIR}/${RUST_STD_BOOTSTRAP} \
${WRKSRC}/build/cache/${BOOTSTRAPS_DATE_${ARCH}:U${BOOTSTRAPS_DATE}}
.endif
${LN} -sf ${DISTDIR}/${DIST_SUBDIR}/${CARGO_BOOTSTRAP} \
${WRKSRC}/build/cache/${BOOTSTRAPS_DATE_${ARCH}:U${BOOTSTRAPS_DATE}}
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200031
+.if ${NEED_ABI_PATCH} == 1
${TAR} -x -C ${WRKSRC} -f ${DISTDIR}/${DIST_SUBDIR}/${RUST_STD_BOOTSTRAP}
${CC} ${CFLAGS} -fPIC -c -o ${WRKSRC}/old_fstat.o ${FILESDIR}/old_fstat.c
(set -ex; cd ${WRKSRC}; \