aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rust
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-11-08 06:17:36 +0800
committerriggs <riggs@FreeBSD.org>2015-11-08 06:17:36 +0800
commit6dead7ee50ffb3660603eafcb657cdcc69fc2960 (patch)
tree7c8cec70a6b331ccec3167ce612ee4d6fec67842 /lang/rust
parentece0ab4ea39e29f42400f5ee497f21ec650369a1 (diff)
downloadfreebsd-ports-gnome-6dead7ee50ffb3660603eafcb657cdcc69fc2960.tar.gz
freebsd-ports-gnome-6dead7ee50ffb3660603eafcb657cdcc69fc2960.tar.zst
freebsd-ports-gnome-6dead7ee50ffb3660603eafcb657cdcc69fc2960.zip
- Take maintainership
- Provide target for 'make test': Use bundled rust regression test suite - Use bundled LLVM for now: Built with it, rust passes more regression tests - Bump PORTREVISION
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile13
-rw-r--r--lang/rust/files/patch-src_llvm_utils_llvm-build_llvmbuild_main.py11
2 files changed, 20 insertions, 4 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 402451550d6d..1818add34ed5 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rust
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
http://static.rust-lang.org/stage0-snapshots/:bootstrap
@@ -11,7 +12,7 @@ DISTFILES= ${RUST_SOURCE}:src \
${RUST_BOOT}:bootstrap
EXTRACT_ONLY= ${RUST_SOURCE}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= riggs@FreeBSD.org
COMMENT= Language with a focus on memory safety and concurrency
LICENSE= APACHE20 \
@@ -58,9 +59,9 @@ CONFIGURE_ARGS= --disable-valgrind --disable-docs \
--release-channel=${RUST_CHANNEL}
# Use LLVM from ports, instead of the copy shipped with rust.
-LLVM_VER= 36
-BUILD_DEPENDS+= llvm${LLVM_VER}>=0:${PORTSDIR}/devel/llvm${LLVM_VER}
-CONFIGURE_ARGS+=--llvm-root=${LOCALBASE}/llvm${LLVM_VER}
+#LLVM_VER= 36
+#BUILD_DEPENDS+= llvm${LLVM_VER}>=0:${PORTSDIR}/devel/llvm${LLVM_VER}
+#CONFIGURE_ARGS+=--llvm-root=${LOCALBASE}/llvm${LLVM_VER}
.if defined(BATCH) || defined(PACKAGE_BUILDING)
MAKE_ARGS+= VERBOSE=1
@@ -71,6 +72,10 @@ LLNEXTGEN_DESC= Build with grammar verification
LLNEXTGEN_BUILD_DEPENDS= LLnextgen:${PORTSDIR}/devel/llnextgen
+# Note that make test does not work when rust is already installed
+TEST_TARGET= check
+TEST_ENV+= ALLOW_NONZERO_RLIMIT_CORE=1
+
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
diff --git a/lang/rust/files/patch-src_llvm_utils_llvm-build_llvmbuild_main.py b/lang/rust/files/patch-src_llvm_utils_llvm-build_llvmbuild_main.py
new file mode 100644
index 000000000000..50b7587e40f8
--- /dev/null
+++ b/lang/rust/files/patch-src_llvm_utils_llvm-build_llvmbuild_main.py
@@ -0,0 +1,11 @@
+--- src/llvm/utils/llvm-build/llvmbuild/main.py.orig 2015-10-28 01:10:50 UTC
++++ src/llvm/utils/llvm-build/llvmbuild/main.py
+@@ -719,6 +719,8 @@ def add_magic_target_components(parser,
+ # We handle a few special cases of target names here for historical
+ # reasons, as these are the names configure currently comes up with.
+ native_target_name = { 'x86' : 'X86',
++ 'i386' : 'X86',
++ 'amd64' : 'X86',
+ 'x86_64' : 'X86',
+ 'Unknown' : None }.get(opts.native_target,
+ opts.native_target)