aboutsummaryrefslogtreecommitdiffstats
path: root/lang/sbcl/Makefile
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-11-09 02:47:52 +0800
committermnag <mnag@FreeBSD.org>2005-11-09 02:47:52 +0800
commit8e908e7ec4255281ad7647f94b1386993e3f989a (patch)
treee6aed271f8a1d2ba503468bb74fda8a6ae1d18b7 /lang/sbcl/Makefile
parentef6636d534920e2bc4762b6c0cfef26f2245a14f (diff)
downloadfreebsd-ports-gnome-8e908e7ec4255281ad7647f94b1386993e3f989a.tar.gz
freebsd-ports-gnome-8e908e7ec4255281ad7647f94b1386993e3f989a.tar.zst
freebsd-ports-gnome-8e908e7ec4255281ad7647f94b1386993e3f989a.zip
Fix build and respect CFLAGS
Add SHA256 Notified by: kris
Diffstat (limited to 'lang/sbcl/Makefile')
-rw-r--r--lang/sbcl/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index f7752a7dbef7..4e8bc08a030c 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -28,6 +28,7 @@ BUILD_DEPENDS= lisp:${PORTSDIR}/lang/cmucl
LISP_CMD= "lisp -noinit -batch"
.endif
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -51,7 +52,10 @@ BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
.endif
post-patch:
- @${FIND} ${WRKSRC} -name '*.orig' -delete
+ @${REINPLACE_CMD} -E -e \
+ 's|CFLAGS = .*|CFLAGS = ${CFLAGS} -DSBCL_HOME=\\"${PREFIX}/lib/sbcl/\\"|' \
+ ${WRKSRC}/src/runtime/GNUmakefile
+ @${FIND} ${WRKSRC} -name '*.orig' -o -name '*.bak' | ${XARGS} ${RM}
do-build:
(cd ${WRKSRC} && ${SETENV} INSTALL_ROOT=${PREFIX} \