aboutsummaryrefslogtreecommitdiffstats
path: root/lang/sbcl/Makefile
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2013-01-05 22:13:46 +0800
committerbf <bf@FreeBSD.org>2013-01-05 22:13:46 +0800
commit34a9c276539bd9f5b80735a975778d9d1eb3a89e (patch)
tree8136c892829e1c0f76dfd5615929ee14ab8c1051 /lang/sbcl/Makefile
parentb185f6be3370c0363cc8475ce75328a8ca9ce9c3 (diff)
downloadfreebsd-ports-gnome-34a9c276539bd9f5b80735a975778d9d1eb3a89e.tar.gz
freebsd-ports-gnome-34a9c276539bd9f5b80735a975778d9d1eb3a89e.tar.zst
freebsd-ports-gnome-34a9c276539bd9f5b80735a975778d9d1eb3a89e.zip
update lang/sbcl to 1.1.3 and adjust dependent ports
Diffstat (limited to 'lang/sbcl/Makefile')
-rw-r--r--lang/sbcl/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index 12f7cb7f4916..189c6b663784 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= sbcl
-PORTVERSION= 1.1.2
+PORTVERSION= 1.1.3
PORTEPOCH= 1
CATEGORIES= lang lisp
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
@@ -118,10 +118,16 @@ MAKE_SH_ARGS+= --with-sb-futex
.else
MAKE_SH_ARGS+= --without-sb-futex
.endif
-.if defined(WITH_SAFEPOINT)
+.if defined(WITH_SAFEPOINT) || defined(WITH_STRICT_SAFEPOINT)
MAKE_SH_ARGS+= --with-sb-safepoint --with-sb-thruption --with-sb-wtimer
+.if defined(WITH_STRICT_SAFEPOINT)
+MAKE_SH_ARGS+= --with-sb-safepoint-strictly
.else
-MAKE_SH_ARGS+= --without-sb-safepoint --without-sb-thruption --without-sb-wtimer
+MAKE_SH_ARGS+= --without-sb-safepoint-strictly
+.endif
+.else
+MAKE_SH_ARGS+= --without-sb-safepoint --without-sb-safepoint-strictly \
+ --without-sb-thruption --without-sb-wtimer
.endif
.else
MAKE_SH_ARGS+= --without-sb-thread