aboutsummaryrefslogtreecommitdiffstats
path: root/lang/sbcl/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-09 17:31:29 +0800
committermiwi <miwi@FreeBSD.org>2006-12-09 17:31:29 +0800
commit4ea439cd93927f79dce9fb901846e9368fc9b417 (patch)
treefdd91c64ba47213c87cc41b0873ea81a2ccfafd8 /lang/sbcl/Makefile
parent0c3c4e49bf56bbc52c880be21b567d0f98dcd1b4 (diff)
downloadfreebsd-ports-gnome-4ea439cd93927f79dce9fb901846e9368fc9b417.tar.gz
freebsd-ports-gnome-4ea439cd93927f79dce9fb901846e9368fc9b417.tar.zst
freebsd-ports-gnome-4ea439cd93927f79dce9fb901846e9368fc9b417.zip
- Fix handling of floating point exception on AMD64.
- Support build on AMD64 with threading. PR: ports/106506 Submitted by: NIIMI Satoshi <sa2c@sa2c.net>
Diffstat (limited to 'lang/sbcl/Makefile')
-rw-r--r--lang/sbcl/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index b03a250667b5..d68df96e90c4 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sbcl
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= lang lisp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sbcl
@@ -23,7 +24,7 @@ USE_GMAKE= yes
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/*
-# Can currently only bootstrap using cmucl, which is i386-only
+# SBCL is a native code compiler: it must be ported per architecture.
ONLY_FOR_ARCHS= i386 amd64
MAN1= sbcl.1
@@ -56,10 +57,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib32/compat/libc.so.4:${PORTSDIR}/misc/compat4x
BROKEN= Does not compile on 4.x with threading
.endif
-.if defined(WITH_THREADS) && ${ARCH} == amd64
-BROKEN= Does not compile on AMD64 with threading
-.endif
-
.if ${ARCH} == i386
PLIST_SUB+= I386_ONLY=""
.else
@@ -93,11 +90,6 @@ test: build
(cd ${WRKSRC}/tests && ${SH} run-tests.sh)
pre-everything::
-.if ${ARCH} == amd64
- @${ECHO_MSG} "====>"
- @${ECHO_MSG} "====> WARNING: AMD64 support is experimental."
- @${ECHO_MSG} "====>"
-.else
.if !defined(WITH_THREADS) && ${OSVERSION} >= 600000
@${ECHO_MSG} "====>"
@${ECHO_MSG} "====> To enable experimental threading support, define WITH_THREADS."
@@ -107,6 +99,5 @@ pre-everything::
@${ECHO_MSG} "====> WARNING: Current threading support is very unstable on FreeBSD 5.x."
@${ECHO_MSG} "====>"
.endif
-.endif
.include <bsd.port.post.mk>