aboutsummaryrefslogtreecommitdiffstats
path: root/lang/scsh/Makefile
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1997-01-03 08:37:20 +0800
committermax <max@FreeBSD.org>1997-01-03 08:37:20 +0800
commit0d2f7aee0dd6edf26198bcc785942f37e57d2aa4 (patch)
tree22f48787590433e38c4a8de2c9f1c9d791d21629 /lang/scsh/Makefile
parent4ed294cef54435f4cd101225bd9502990b47beb2 (diff)
downloadfreebsd-ports-gnome-0d2f7aee0dd6edf26198bcc785942f37e57d2aa4.tar.gz
freebsd-ports-gnome-0d2f7aee0dd6edf26198bcc785942f37e57d2aa4.tar.zst
freebsd-ports-gnome-0d2f7aee0dd6edf26198bcc785942f37e57d2aa4.zip
New port, scsh:
A Unix shell embedded into Scheme, with access to all Posix calls Reviewed by: max Submitted by: cracauer@cons.org "Martin Cracauer"
Diffstat (limited to 'lang/scsh/Makefile')
-rw-r--r--lang/scsh/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/lang/scsh/Makefile b/lang/scsh/Makefile
new file mode 100644
index 000000000000..6168d9d205a9
--- /dev/null
+++ b/lang/scsh/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: scsh
+# Version required: 0.4.4
+# Date created: Nov, 11, 1996
+# Whom: cracauer@cons.org "Martin Cracauer"
+#
+# $Id: Makefile,v 1.1 1996/11/28 16:18:38 cracauer Exp $
+#
+
+DISTNAME= scsh-0.4.4
+CATEGORIES= shells lang
+MASTER_SITES= ftp://ftp-swiss.ai.mit.edu/pub/su/scsh/
+
+MAINTAINER= cracauer@cons.org
+
+GNU_CONFIGURE= yes
+
+NO_CDROM= "Wait for next release by the author's request"
+ALL_TARGET= enough
+MAN1= scsh.1
+STRIP=
+
+post-install:
+ @strip ${PREFIX}/bin/scsh
+ (cd ${WRKSRC} ; \
+ ${INSTALL_DATA} README RELEASE NEWS COPYING ${PREFIX}/lib/scsh/doc)
+ ${RM} -f ${PREFIX}/share/doc/scsh
+ ln -fs ${PREFIX}/lib/scsh/doc ${PREFIX}/share/doc/scsh
+
+.include <bsd.port.mk>