aboutsummaryrefslogtreecommitdiffstats
path: root/lang/scsh/files
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1997-01-03 08:37:20 +0800
committermax <max@FreeBSD.org>1997-01-03 08:37:20 +0800
commit0d2f7aee0dd6edf26198bcc785942f37e57d2aa4 (patch)
tree22f48787590433e38c4a8de2c9f1c9d791d21629 /lang/scsh/files
parent4ed294cef54435f4cd101225bd9502990b47beb2 (diff)
downloadfreebsd-ports-gnome-0d2f7aee0dd6edf26198bcc785942f37e57d2aa4.tar.gz
freebsd-ports-gnome-0d2f7aee0dd6edf26198bcc785942f37e57d2aa4.tar.zst
freebsd-ports-gnome-0d2f7aee0dd6edf26198bcc785942f37e57d2aa4.zip
New port, scsh:
A Unix shell embedded into Scheme, with access to all Posix calls Reviewed by: max Submitted by: cracauer@cons.org "Martin Cracauer"
Diffstat (limited to 'lang/scsh/files')
-rw-r--r--lang/scsh/files/patch-aa39
-rw-r--r--lang/scsh/files/patch-ab19
-rw-r--r--lang/scsh/files/patch-ac19
-rw-r--r--lang/scsh/files/patch-ad19
-rw-r--r--lang/scsh/files/patch-ae19
5 files changed, 115 insertions, 0 deletions
diff --git a/lang/scsh/files/patch-aa b/lang/scsh/files/patch-aa
new file mode 100644
index 000000000000..22f97bee64ee
--- /dev/null
+++ b/lang/scsh/files/patch-aa
@@ -0,0 +1,39 @@
+*** Makefile.in.original Tue Nov 26 14:44:19 1996
+--- Makefile.in Thu Nov 28 15:29:24 1996
+***************
+*** 137,143 ****
+
+ # The following is the first rule and therefore the "make" command's
+ # default target.
+! enough: $(VM) $(IMAGE) script $(LIBCIG) scsh $(LIBSCSH) $(MANPAGE) .notify
+
+ # The developers are curious to know. Don't be concerned if this fails.
+ # You may comment these lines out if you wish to be discourteous.
+--- 137,143 ----
+
+ # The following is the first rule and therefore the "make" command's
+ # default target.
+! enough: $(VM) $(IMAGE) script $(LIBCIG) scsh $(LIBSCSH) $(MANPAGE)
+
+ # The developers are curious to know. Don't be concerned if this fails.
+ # You may comment these lines out if you wish to be discourteous.
+***************
+*** 250,255 ****
+--- 250,256 ----
+ $(RM) -r $(LIB).old
+ if [ -d $(LIB) ] ; then mv $(LIB) $(LIB).old ; fi
+ mkdir $(LIB)
++ mkdir $(LIB)/emacs
+ mkdir $(LIB)/big
+ mkdir $(LIB)/cig
+ mkdir $(LIB)/doc
+***************
+*** 286,291 ****
+--- 287,293 ----
+ $(LIB)/misc $(LIB)/link $(LIB)/vm $(LIB)/doc
+ for f in $(srcdir)/rts/*num.scm; \
+ do $(INSTALL_DATA) $$f $(LIB)/rts/; done
++ for f in $(srcdir)/emacs/*; do $(INSTALL_DATA) $$f $(LIB)/emacs/; done
+ for f in $(srcdir)/env/*.scm; do $(INSTALL_DATA) $$f $(LIB)/env/; done
+ for f in $(srcdir)/big/*.scm; do $(INSTALL_DATA) $$f $(LIB)/big/; done
+ for f in $(srcdir)/opt/*.scm; do $(INSTALL_DATA) $$f $(LIB)/opt/; done
diff --git a/lang/scsh/files/patch-ab b/lang/scsh/files/patch-ab
new file mode 100644
index 000000000000..a75d1e93ac41
--- /dev/null
+++ b/lang/scsh/files/patch-ab
@@ -0,0 +1,19 @@
+*** env/command.scm.original Tue Nov 26 15:59:38 1996
+--- env/command.scm Tue Nov 26 15:59:46 1996
+***************
+*** 546,552 ****
+ ((char=? (string-ref line 0) #\n) #f)
+ (else (loop count)))))))
+
+! (define *y-or-n-eof-count* 100)
+
+ (define (read-line port)
+ (let loop ((l '()))
+--- 546,552 ----
+ ((char=? (string-ref line 0) #\n) #f)
+ (else (loop count)))))))
+
+! (define *y-or-n-eof-count* 0)
+
+ (define (read-line port)
+ (let loop ((l '()))
diff --git a/lang/scsh/files/patch-ac b/lang/scsh/files/patch-ac
new file mode 100644
index 000000000000..42c68f84edeb
--- /dev/null
+++ b/lang/scsh/files/patch-ac
@@ -0,0 +1,19 @@
+*** configure.in.original Tue Nov 26 17:10:41 1996
+--- configure.in Tue Nov 26 17:11:07 1996
+***************
+*** 220,226 ****
+ fi
+
+ AR=${AR-"ar cq"}
+! TMPDIR=${TMPDIR-"/usr/tmp"}
+
+ case "$host" in
+
+--- 220,226 ----
+ fi
+
+ AR=${AR-"ar cq"}
+! TMPDIR=${TMPDIR-"/var/tmp"}
+
+ case "$host" in
+
diff --git a/lang/scsh/files/patch-ad b/lang/scsh/files/patch-ad
new file mode 100644
index 000000000000..57efb8d7d373
--- /dev/null
+++ b/lang/scsh/files/patch-ad
@@ -0,0 +1,19 @@
+*** configure.original Tue Nov 26 17:55:51 1996
+--- configure Tue Nov 26 17:55:58 1996
+***************
+*** 1017,1023 ****
+ fi
+
+ AR=${AR-"ar cq"}
+! TMPDIR=${TMPDIR-"/usr/tmp"}
+
+ case "$host" in
+
+--- 1017,1023 ----
+ fi
+
+ AR=${AR-"ar cq"}
+! TMPDIR=${TMPDIR-"/var/tmp"}
+
+ case "$host" in
+
diff --git a/lang/scsh/files/patch-ae b/lang/scsh/files/patch-ae
new file mode 100644
index 000000000000..f7eec1bab769
--- /dev/null
+++ b/lang/scsh/files/patch-ae
@@ -0,0 +1,19 @@
+*** scsh/scsh.scm.original Tue Nov 26 17:15:00 1996
+--- scsh/scsh.scm Tue Nov 26 17:15:06 1996
+***************
+*** 298,304 ****
+ (list (string-append (car maybe-prefix) ".~a"))))))
+
+ (define *temp-file-template*
+! (make-fluid (string-append "/usr/tmp/" (number->string (pid)) ".~a")))
+
+
+ (define (temp-file-iterate maker . maybe-template)
+--- 298,304 ----
+ (list (string-append (car maybe-prefix) ".~a"))))))
+
+ (define *temp-file-template*
+! (make-fluid (string-append "/var/tmp/" (number->string (pid)) ".~a")))
+
+
+ (define (temp-file-iterate maker . maybe-template)