aboutsummaryrefslogtreecommitdiffstats
path: root/lang/sdcc-devel/Makefile
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2006-06-30 13:02:43 +0800
committerdaichi <daichi@FreeBSD.org>2006-06-30 13:02:43 +0800
commitd0b050b83dda15338b9663dbd7d987bcc7806917 (patch)
tree56945db6169b768f36e5e8d1ce5b4f5f73f74806 /lang/sdcc-devel/Makefile
parentb40325a44108ecae0a6a81ccfcdac6f74de8e1ca (diff)
downloadfreebsd-ports-gnome-d0b050b83dda15338b9663dbd7d987bcc7806917.tar.gz
freebsd-ports-gnome-d0b050b83dda15338b9663dbd7d987bcc7806917.tar.zst
freebsd-ports-gnome-d0b050b83dda15338b9663dbd7d987bcc7806917.zip
lang/sdcc-devel: update to version 2.5.6.2006.06.29
- Update of lang/sdcc-devel which mainly brings in support for more PIC microcontrollers. PR: lang/sdcc-devel Submitted by: maintainer
Diffstat (limited to 'lang/sdcc-devel/Makefile')
-rw-r--r--lang/sdcc-devel/Makefile34
1 files changed, 27 insertions, 7 deletions
diff --git a/lang/sdcc-devel/Makefile b/lang/sdcc-devel/Makefile
index 5b3a17e29012..b7a771ff4c33 100644
--- a/lang/sdcc-devel/Makefile
+++ b/lang/sdcc-devel/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= sdcc
-PORTVERSION= 2.5.4.2005.11.15
+PORTVERSION= 2.5.6.2006.06.29
CATEGORIES= lang
MASTER_SITES= http://sdcc.sourceforge.net/snapshots/sdcc-src/ \
http://www.kalimero.be/mirror/
-DISTNAME= ${PORTNAME}-src-20051115
+DISTNAME= ${PORTNAME}-src-20060629-4251
MAINTAINER= tijl@ulyssis.org
COMMENT= Small Device C Compiler
@@ -29,11 +29,20 @@ OPTIONS= MCS51 "Intel mcs51 port" on \
PIC16 "PIC16 port" on \
XA51 "XA51 port" on \
HC08 "HC08 port" on \
+ DEVLIB "Device libraries" on \
UCSIM "The ucSim simulator" on \
PACKIHX "A tool to pack (compress) Intel hex files" on
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_MCS51) && defined(WITHOUT_DS390)
+CONFIGURE_ARGS+= --disable-51
+PLIST_SUB+= MCS51DS390="@comment "
+.else
+USE_AUTOTOOLS+= autoconf:259
+PLIST_SUB+= MCS51DS390=""
+.endif
+
.if defined(WITHOUT_MCS51)
CONFIGURE_ARGS+= --disable-mcs51-port
PLIST_SUB+= MCS51="@comment "
@@ -42,14 +51,17 @@ PLIST_SUB+= MCS51=""
.endif
.if defined(WITHOUT_Z80)
-CONFIGURE_ARGS+= --disable-gbz80-port --disable-z80-port
+CONFIGURE_ARGS+= --disable-gbz80-port --disable-z80-port --disable-z80
PLIST_SUB+= Z80="@comment "
.else
PLIST_SUB+= Z80=""
.endif
.if defined(WITHOUT_AVR)
-CONFIGURE_ARGS+= --disable-avr-port
+CONFIGURE_ARGS+= --disable-avr-port --disable-avr
+PLIST_SUB+= AVR="@comment "
+.else
+PLIST_SUB+= AVR=""
.endif
.if defined(WITHOUT_DS390)
@@ -63,6 +75,7 @@ PLIST_SUB+= DS390=""
CONFIGURE_ARGS+= --disable-pic-port
PLIST_SUB+= PIC="@comment "
.else
+BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
PLIST_SUB+= PIC=""
.endif
@@ -79,18 +92,25 @@ CONFIGURE_ARGS+= --disable-xa51-port
.endif
.if defined(WITHOUT_HC08)
-CONFIGURE_ARGS+= --disable-hc08-port
+CONFIGURE_ARGS+= --disable-hc08-port --disable-hc08
PLIST_SUB+= HC08="@comment "
.else
PLIST_SUB+= HC08=""
.endif
+.if defined(WITHOUT_DEVLIB)
+CONFIGURE_ARGS+= --disable-device-lib
+PLIST_SUB+= DEVLIB="@comment "
+.else
+PLIST_SUB+= DEVLIB=""
+.endif
+
.if defined(WITHOUT_UCSIM)
CONFIGURE_ARGS+= --disable-ucsim
PLIST_SUB+= UCSIM="@comment "
.else
-USE_AUTOTOOLS= libtool:15
-LIBTOOLFILES= sim/ucsim/aclocal.m4
+USE_AUTOTOOLS+= libtool:15
+LIBTOOLFILES= sim/ucsim/configure
PLIST_SUB+= UCSIM=""
.endif