aboutsummaryrefslogtreecommitdiffstats
path: root/lang/sdcc/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-07-10 00:22:42 +0800
committerbeech <beech@FreeBSD.org>2011-07-10 00:22:42 +0800
commitbcc055fe2cf65b93932d19a66a5ea9535c320f66 (patch)
treea45c87adc34746d356ea3184c3709071f48eef18 /lang/sdcc/Makefile
parent8ff8b2fd1db413ab643d0897ecc355a51ad7251d (diff)
downloadfreebsd-ports-gnome-bcc055fe2cf65b93932d19a66a5ea9535c320f66.tar.gz
freebsd-ports-gnome-bcc055fe2cf65b93932d19a66a5ea9535c320f66.tar.zst
freebsd-ports-gnome-bcc055fe2cf65b93932d19a66a5ea9535c320f66.zip
- gputils is required by sdcc for working with PIC processors,
and hence should be included in RUN_DEPENDS as well as BUILD_DEPENDS PR: ports/158691 Submitted by: Jason Bacon <jwbacon@tds.net> Approved by: Tijl Coosemans <tijl@coosemans.org> (maintainer)
Diffstat (limited to 'lang/sdcc/Makefile')
-rw-r--r--lang/sdcc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index c3f7edaa0c1a..744202ebb118 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -85,6 +85,7 @@ CONFIGURE_ARGS+= --disable-pic-port
PLIST_SUB+= PIC="@comment "
.else
BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
+RUN_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
PLIST_SUB+= PIC=""
.endif
@@ -93,6 +94,7 @@ CONFIGURE_ARGS+= --disable-pic16-port
PLIST_SUB+= PIC16="@comment "
.else
BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
+RUN_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
PLIST_SUB+= PIC16=""
.endif