aboutsummaryrefslogtreecommitdiffstats
path: root/lang/see-devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-14 20:52:25 +0800
committermiwi <miwi@FreeBSD.org>2006-12-14 20:52:25 +0800
commita0aa045479975d06ca773736226bf08534d03bb0 (patch)
tree44092d9b6ce067b2497e94709c1dfd8453e086bd /lang/see-devel
parent2daa56a44cb6263a8d62b61ba918ef590a27e0a3 (diff)
downloadfreebsd-ports-gnome-a0aa045479975d06ca773736226bf08534d03bb0.tar.gz
freebsd-ports-gnome-a0aa045479975d06ca773736226bf08534d03bb0.tar.zst
freebsd-ports-gnome-a0aa045479975d06ca773736226bf08534d03bb0.zip
- Add DEBUG knob
PR: ports/106665 Submitted by: Simun Mikecin <numisemis@yahoo.com> (maintainer)
Diffstat (limited to 'lang/see-devel')
-rw-r--r--lang/see-devel/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/see-devel/Makefile b/lang/see-devel/Makefile
index 999c9ad8d757..e44eb8455f78 100644
--- a/lang/see-devel/Makefile
+++ b/lang/see-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= see
PORTVERSION= 2.0.1131
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang devel
MASTER_SITES= http://www.powerband.net.au/~david.leonard/ \
http://freshmeat.net/redir/see/45974/url_tgz/
@@ -17,7 +17,8 @@ MAINTAINER= numisemis@yahoo.com
COMMENT= Simple ECMAScript Engine (SEE)
OPTIONS= GC "Use Boehm-Weiser garbage collection package" on \
- OPTIMIZED_CFLAGS "Enable some additional optimizations" off
+ OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
+ SEE_DEBUG "Internal SEE library debugging" off
CONFLICTS= see-[0-9]*
@@ -38,6 +39,10 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
BROKEN= does not build on 4.x
.endif
+.if !defined(WITH_SEE_DEBUG)
+CFLAGS+= -DNDEBUG
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -fomit-frame-pointer
.endif