aboutsummaryrefslogtreecommitdiffstats
path: root/lang/see/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-07 17:41:23 +0800
committerbapt <bapt@FreeBSD.org>2014-07-07 17:41:23 +0800
commitc061de05901d8333137202de9c0c984e260c4515 (patch)
tree145fc2d3a66a12126b12bcb3996fa1df4ce2a52c /lang/see/Makefile
parentf270fbd0a5d251f3a692024007e299f40a421f55 (diff)
downloadfreebsd-ports-gnome-c061de05901d8333137202de9c0c984e260c4515.tar.gz
freebsd-ports-gnome-c061de05901d8333137202de9c0c984e260c4515.tar.zst
freebsd-ports-gnome-c061de05901d8333137202de9c0c984e260c4515.zip
Update to 3.1
Support stage Convert to USES=libtool Remove the -devel version which is outdated an no more needed PR: 187954 Submitted by: numisemis@yahoo.com (maintainer)
Diffstat (limited to 'lang/see/Makefile')
-rw-r--r--lang/see/Makefile55
1 files changed, 19 insertions, 36 deletions
diff --git a/lang/see/Makefile b/lang/see/Makefile
index 6c258ea149e0..712ed616b6da 100644
--- a/lang/see/Makefile
+++ b/lang/see/Makefile
@@ -2,68 +2,51 @@
# $FreeBSD$
PORTNAME= see
-PORTVERSION= 2.0.1131
-PORTREVISION= 1
+PORTVERSION= 3.1.1424
CATEGORIES= lang devel
-MASTER_SITES= http://www.powerband.net.au/~david.leonard/ \
- http://freshmeat.net/redir/see/45974/url_tgz/
+MASTER_SITES= http://download.openpkg.org/components/cache/see/ \
+ http://lil.fr.distfiles.macports.org/see/ \
+ ftp://ftp7.freebsd.org/sites/distfiles.macports.org/see/ \
+ ftp://ftp.mirrorservice.org/sites/distfiles.macports.org/see/ \
+ ftp://kuiper.mirrorservice.org/sites/distfiles.macports.org/see/ \
+ ftp://copernicus.mirrorservice.org/sites/distfiles.macports.org/see/ \
+ ftp://ftp2.uk.i-scream.org/sites/distfiles.macports.org/see/ \
+ ftp://mirror.csclub.uwaterloo.ca/MacPorts/mpdistfiles/see/
MAINTAINER= numisemis@yahoo.com
COMMENT= Simple ECMAScript Engine (SEE)
-OPTIONS_DEFINE= GC OPTIMIZED_CFLAGS SEE_DEBUG THREADS DOCS
-OPTIONS_DEFAULT= GC THREADS
+OPTIONS_DEFINE= GC SEE_DEBUG DOCS
+OPTIONS_DEFAULT= GC
GC_DESC= Use Boehm-Weiser garbage collection package
SEE_DEBUG_DESC= Internal SEE library debugging
CONFLICTS= see-devel-[0-9]*
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_LDCONFIG= yes
-USES= perl5
+USES= libtool pathfix perl5
USE_PERL5= build
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+CFLAGS+= -O3 -fomit-frame-pointer
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMULTIPLE_THREADS}
-CFLAGS+= -DMULTIPLE_THREADS
-.endif
-
-.if ! ${PORT_OPTIONS:MSEE_DEBUG}
-CFLAGS+= -DNDEBUG
-.endif
-
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-CFLAGS+= -O3 -fomit-frame-pointer
-.endif
-
-.if ${PORT_OPTIONS:MGC}
-LIB_DEPENDS+= gc:${PORTSDIR}/devel/boehm-gc
-.else
-CONFIGURE_ARGS+= --without-boehm-gc
-.if ! ${PORT_OPTIONS:MTHREADS}
-PTHREAD_CFLAGS=
-PTHREAD_LIBS=
-.endif
-.endif
+SEE_DEBUG_CFLAGS_OFF= -DNDEBUG
+GC_LIB_DEPENDS= libgc.so:${PORTSDIR}/devel/boehm-gc
+GC_CONFIGURE_WITH= boehm-gc
post-patch:
@${REINPLACE_CMD} -e "s|PACKAGE_BUGREPORT='leonard@users|PACKAGE_BUGREPORT='leonard\\\@users|" \
${WRKSRC}/configure
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in doc/USAGE.html AUTHORS NEWS README TODO COPYING
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>