aboutsummaryrefslogtreecommitdiffstats
path: root/lang/see
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-12 14:05:03 +0800
committerbapt <bapt@FreeBSD.org>2013-05-12 14:05:03 +0800
commit5cdd435b52ee9c3569a74925bf6839c9fae9143b (patch)
treef04b4da09af88440a84fa754093dfc6c176a91c1 /lang/see
parentf1a65685968e16bcfbd626772d7b1599f4566096 (diff)
downloadfreebsd-ports-gnome-5cdd435b52ee9c3569a74925bf6839c9fae9143b.tar.gz
freebsd-ports-gnome-5cdd435b52ee9c3569a74925bf6839c9fae9143b.tar.zst
freebsd-ports-gnome-5cdd435b52ee9c3569a74925bf6839c9fae9143b.zip
Convert to new options framework
Diffstat (limited to 'lang/see')
-rw-r--r--lang/see/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/lang/see/Makefile b/lang/see/Makefile
index bf0a50f424d8..b6b8519d4bb6 100644
--- a/lang/see/Makefile
+++ b/lang/see/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: see
-# Date created: 29 Oct 2005
-# Whom: Simun Mikecin <numisemis@yahoo.com>
-#
+# Created by: Simun Mikecin <numisemis@yahoo.com>
# $FreeBSD$
-#
PORTNAME= see
PORTVERSION= 2.0.1131
@@ -15,10 +11,10 @@ MASTER_SITES= http://www.powerband.net.au/~david.leonard/ \
MAINTAINER= numisemis@yahoo.com
COMMENT= Simple ECMAScript Engine (SEE)
-OPTIONS= GC "Use Boehm-Weiser garbage collection package" on \
- OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
- SEE_DEBUG "Internal SEE library debugging" off \
- MULTIPLE_THREADS "Enable thread-safety" on
+OPTIONS_DEFINE= GC OPTIMIZED_CFLAGS SEE_DEBUG THREADS DOCS
+OPTIONS_DEFAULT= GC THREADS
+GC_DESC= Use Boehm-Weiser garbage collection package
+SEE_DEBUG_DESC= Internal SEE library debugging
CONFLICTS= see-devel-[0-9]*
@@ -34,23 +30,23 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if defined(WITH_MULTIPLE_THREADS)
+.if ${PORT_OPTIONS:MMULTIPLE_THREADS}
CFLAGS+= -DMULTIPLE_THREADS
.endif
-.if !defined(WITH_SEE_DEBUG)
+.if ! ${PORT_OPTIONS:MSEE_DEBUG}
CFLAGS+= -DNDEBUG
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -fomit-frame-pointer
.endif
-.if defined(WITH_GC)
+.if ${PORT_OPTIONS:MGC}
LIB_DEPENDS+= gc:${PORTSDIR}/devel/boehm-gc
.else
CONFIGURE_ARGS+= --without-boehm-gc
-.if !defined(WITH_MULTIPLE_THREADS)
+.if ! ${PORT_OPTIONS:MTHREADS}
PTHREAD_CFLAGS=
PTHREAD_LIBS=
.endif
@@ -60,7 +56,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|PACKAGE_BUGREPORT='leonard@users|PACKAGE_BUGREPORT='leonard\\\@users|" \
${WRKSRC}/configure
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
.for f in doc/USAGE.html AUTHORS NEWS README TODO COPYING