aboutsummaryrefslogtreecommitdiffstats
path: root/lang/seed7
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-07-08 15:29:30 +0800
committergahr <gahr@FreeBSD.org>2014-07-08 15:29:30 +0800
commit65b9cc29412615aec29beb58135e076baf912041 (patch)
tree255a97073a28995615cf5e625f992fb9e788821a /lang/seed7
parenta97534111a8e08a28bbe5d83a58a7ccd32d0162a (diff)
downloadfreebsd-ports-gnome-65b9cc29412615aec29beb58135e076baf912041.tar.gz
freebsd-ports-gnome-65b9cc29412615aec29beb58135e076baf912041.tar.zst
freebsd-ports-gnome-65b9cc29412615aec29beb58135e076baf912041.zip
- Update to 05_20140706
Changes: * The interpreter has been improved to recognize integer overflow. Now the exception NUMERIC_ERROR is raised, when a program triggers an integer overflow. The checks for overflow are done in software, but the overhead is small. With overflow checks the interpreter needs 0.5% (zero point five percent) more run-time to execute the program chkint.sd7 (verified with gcc and valgrind). * A chapter about the Seed7 Structured Syntax Description (S7SSD) has been added to the manual. * The for-until-loops in bitset.s7i and bitsetof.s7i have been improved such that the for-variable has the correct value, when it is used in the until-condition. * The function replaceN has been added to string.s7i. This function does replacements until no occurance of the target string is left. This function is used by toStdPath to replace multiple occurances of a character by one occurance (replace("/a///b////c", "//", "/") returns "/a/b/c"). * The program calc.sd7 has been renamed to calc7.sd7. * The program calc7.sd7 has been changed to accept the commands 'quit' and 'exit'. This commands can be used to exit the program. The possibility to leave the program with an empty input line has been removed. * The program calc7.sd7 has been improved to write the name of the exception, when it has been raised. * The compiler has been improved to allow the generation of overflow checking code. Overflow checking code can be generated for the operators +, -, **, +:= and -:= and the functions abs, succ, pred, incr and decr. Until the rest of the functions is implemented and enough tests have been added to chkint.sd7 the functionality is switched off. * The template FOR_UNTIL_DECLS has been added to forloop.s7i. This template defines for-loops with a condition. * The function abs has been moved from the library math.s7i to the library float.s7i. * Checks for addition, subtraction, multiplication, power and abs have been added to chkint.sd7. * In the compiler the statements to write the C prototypes have been moved from s7c.sd7 to functions in the files comp/xxx_act.s7i (xxx is the abbreviation for the corresponding primitive type). * The functions getReference getParameterAsReference have been added to comp/expr_util.s7i. * The function isit_bool from objutl.c has been replaced by the macro isit_bool (defined in objutl.h). This improves the speed of the interpreter. * The function set_card has been improved to call setCard, which computes the cardinality of a set much quicker.
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile2
-rw-r--r--lang/seed7/distinfo4
2 files changed, 3 insertions, 3 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 00c2eb1271bb..b9b7c3382990 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20140615
+DISTVERSION= 05_20140706
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 944ac24ad1cd..9258f971c233 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20140615.tgz) = 8a308968572e687333aea21c5fc87509f21c4b22910671d41fbc6f1be1afcd0c
-SIZE (seed7_05_20140615.tgz) = 2127026
+SHA256 (seed7_05_20140706.tgz) = 3c45ce5d6c766a02258f8d04ce939a8435cb07aa881ad807b8eb0cbee81f2696
+SIZE (seed7_05_20140706.tgz) = 2145580