aboutsummaryrefslogtreecommitdiffstats
path: root/lang/seed7
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-10-17 16:36:28 +0800
committergahr <gahr@FreeBSD.org>2013-10-17 16:36:28 +0800
commit8bc0a91655429d2485a79e41ee11fdd8d450de79 (patch)
tree5105fdbf37c57a0dd5c16f4ee7238719b261b5ea /lang/seed7
parentecfea5b1997220ed654bac47d5e9abc9ba178620 (diff)
downloadfreebsd-ports-gnome-8bc0a91655429d2485a79e41ee11fdd8d450de79.tar.gz
freebsd-ports-gnome-8bc0a91655429d2485a79e41ee11fdd8d450de79.tar.zst
freebsd-ports-gnome-8bc0a91655429d2485a79e41ee11fdd8d450de79.zip
- Update to 05_20131013
Changes: 20131013: - Libraries for TLS (Transport Layer Security), SSL (Secure Sockets Layer) and HTTPS (HyperText Transfer Protocol Secure) support have been added. The new libraries are: arc4.s7i, asn1.s7i, cipher.s7i, gethttps.s7i, hmac.s7i, pkcs1.s7i, tls.s7i and x509cert.s7i. - Comparison operators for < (proper subset) and > (proper superset) have been added to hashsetof.s7i. - The type digestAlgorithm and the functions msgDigest, blockSize and digestSize have been added to msgdigest.s7i. - The function hex has been added to bytedata.s7i. - The example program castle.sd7 has been improved to avoid, that an item can be dropped on an illegal place. - The library make.s7i has been improved to accept the option -p for the cp command. - Documentation comments have been added to sockbase.s7i, socket.s7i, atom.c, entutl.c, soclib.c, soc_rtl.c and striutl.c. - The padding in the message digest functions of msgdigest.s7i has been corrected. Now the functions pad nothing instead of 64 bytes, when the message length is 55 (mod 64). - The function getHttp in gethttp.s7i has been improved to use a case-insensitive comparison for HTTP header field names. - In exec.c the functions eval_arg_list and dump_arg_list have been improved to avoid reading from freed memory. This occured in very rare cases. - The functions find_action (in actutl.c), fltParse (in flt_rtl.c), cmdConfigValue (in cmd_rtl.c) and find_sysvar (in syvarutl.c) have been improved to use the macros MAX_STRI_EXPORT_LEN and max_utf8_size. - Interpreter and runtime library have been improved to ignore the signal SIGPIPE. Writing to a broken pipe or socket raises the exception FILE_ERROR instead. - The functions bln_and and bln_or in blnlib.c have been improved to return either SYS_TRUE_OBJECT or SYS_FALSE_OBJECT. - The program chkccomp.c has been improved to determine the alignment used by malloc and whether an access to unaligned memory succeeds. - Usages of ALLOC_CHUNK in flistutl.h have been improved to allocate aligned memory the same way as malloc returns aligned memory. - The program chkccomp.c has been improved to define the macro 'inline', when the C compiler does not support the keyword inline. - Occurances of 'INLINE' have been replaced with 'inline' in the files analyze.c, atom.c, big_gmp.c, big_rtl.c, chr_rtl.c, exec.c, findid.c, infile.c, int_rtl.c, numlit.c, parser.c, rfl_data.c, scanner.c, striutl.c, strlib.c, str_rtl.c, syntax.c and ut8_rtl.c. 20130929: - The functions bStriLe, bytesLe, bStriBe and bytesBe have been added to bytedata.s7i. This functions convert an integer to a sequence of bytes. - The compiler has been improved to generate inline code for the action STR_PUSH. This action is used when a character is appended to a string (with the operator &:= ). - The function sendGet has been added to gethttp.s7i. - The functions str_yy_mm_dd and str_hh_mm_ss have been added to time.s7i. - Checks for +:= and -:= have been added to chkbig.sd7. - Checks for bytesBe and bytesLe have been added to chkint.sd7. - Checks for & and &:= have been added to chkstr.sd7. - The function doLocalDeclsOfStatement has been added to the compiler. This function is used to simplify the processing of various statements. - The functions that process the statement actions BIG_GROW, BIG_LSHIFT_ASSIGN, BIG_MULT_ASSIGN, BIG_RSHIFT_ASSIGN, BIG_SHRINK, BLN_CPY, CHR_CPY, CHR_GROW, CHR_SHRINK, ENU_CPY, FIL_CPY, FLT_CPY, FLT_DIV_ASSIGN, FLT_GROW, FLT_MULT_ASSIGN, FLT_SHRINK, INT_AND_ASSIGN, INT_CPY, INT_GROW, INT_LSHIFT_ASSIGN, INT_MULT_ASSIGN, INT_OR_ASSIGN, INT_RSHIFT_ASSIGN, INT_SHRINK, INT_URSHIFT_ASSIGN, REF_CPY, RFL_INCL, SET_EXCL, SET_INCL, SOC_CPY, STR_PUSH and TYP_CPY in the compiler have been simplified. - The functions int_toBStriBe and int_toBStriLe have been added to intlib.c. - The functions intToBStriBe and intToBStriLe have been added to int_rtl.c - In big_rtl.c and big_gmp.c the functions bigFromBytesBe and bigFromBytesLe have been renamed to bigFromByteBufferBe respectively bigFromByteBufferLe. - The performance of the functions bst_cmp (in bstlib.c), bstCmp (in bst_rtl.c) and strMult (in str_rtl.c) has been improved. - The macro 'unlikely' has been added to functions in bst_rtl.c.
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile30
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/pkg-plist10
3 files changed, 27 insertions, 17 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 8aa69d79e4e4..e932f9bffd11 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20130908
+DISTVERSION= 05_20131013
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -13,8 +13,9 @@ COMMENT= High-level, extensible programming language
LICENSE= LGPL21
+OPTIONS_DEFINE= DOCS EXAMPLES
+
USE_XORG= x11
-MAN1= s7.1 s7c.1
ONLY_FOR_ARCHS= i386 amd64 sparc64
@@ -32,7 +33,6 @@ S7_LIBS= s7_comp.a s7_con.a s7_draw.a s7_data.a seed7_05.a
PORTEXAMPLES= *
PORTDOCS= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
MAKEFILE= mk_freebsd.mk
@@ -47,29 +47,29 @@ do-build:
do-install:
# install interpreter and compiler
- ${INSTALL_PROGRAM} ${WRKSRC}/../bin/s7 ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/../prg/s7c ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/../bin/s7 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/../prg/s7c ${STAGEDIR}${PREFIX}/bin
# install seed7 library
- ${INSTALL} -d ${SEED7_LIBRARY}
- cd ${WRKSRC}/../lib && ${COPYTREE_SHARE} '*.s7i' ${SEED7_LIBRARY}
+ ${INSTALL} -d ${STAGEDIR}${SEED7_LIBRARY}
+ cd ${WRKSRC}/../lib && ${COPYTREE_SHARE} '*.s7i' ${STAGEDIR}${SEED7_LIBRARY}
# install static libraries
- ${INSTALL} -d ${S7_LIB_DIR}
+ ${INSTALL} -d ${STAGEDIR}${S7_LIB_DIR}
.for s7_lib in ${S7_LIBS}
- ${INSTALL_DATA} ${WRKSRC}/../bin/${s7_lib} ${S7_LIB_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/../bin/${s7_lib} ${STAGEDIR}${S7_LIB_DIR}
.endfor
# install PORTDOCS
.if ${PORT_OPTIONS:MDOCS}
- ${INSTALL} -d ${DOCSDIR}
- cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
+ ${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
.endif
# install PORTEXAMPLES
.if ${PORT_OPTIONS:MEXAMPLES}
- ${INSTALL} -d ${EXAMPLESDIR}
- cd ${WRKSRC}/../prg && ${COPYTREE_SHARE} '*.dna *.sd7 *.dat *.s7i' ${EXAMPLESDIR}
+ ${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/../prg && ${COPYTREE_SHARE} '*.dna *.sd7 *.dat *.s7i' ${STAGEDIR}${EXAMPLESDIR}
.endif
# insall man pages
- ${INSTALL_DATA} ${WRKSRC}/../doc/s7.1 ${MANPREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/../doc/s7c.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/../doc/s7.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/../doc/s7c.1 ${STAGEDIR}${PREFIX}/man/man1
regression-test: build
cd ${WRKSRC} && ${MAKE} -f ${MAKEFILE} test
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 9188d61245e7..277074204f80 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20130908.tgz) = dc06a2f58774d4f152e0e433d6983d637c426b02f223679b0d86ee5e1368616a
-SIZE (seed7_05_20130908.tgz) = 1944548
+SHA256 (seed7_05_20131013.tgz) = 9067760e862f4a9012e970fd341c5cae30c8b57bf2f4c31d4e441e6bade822a3
+SIZE (seed7_05_20131013.tgz) = 1974721
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index 8c8841cf9ba2..51cd52cbbaa3 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -5,6 +5,14 @@ lib/seed7/bin/s7_con.a
lib/seed7/bin/s7_data.a
lib/seed7/bin/s7_draw.a
lib/seed7/bin/seed7_05.a
+lib/seed7/lib/arc4.s7i
+lib/seed7/lib/asn1.s7i
+lib/seed7/lib/cipher.s7i
+lib/seed7/lib/gethttps.s7i
+lib/seed7/lib/hmac.s7i
+lib/seed7/lib/pkcs1.s7i
+lib/seed7/lib/tls.s7i
+lib/seed7/lib/x509cert.s7i
lib/seed7/lib/array.s7i
lib/seed7/lib/bigfile.s7i
lib/seed7/lib/bigint.s7i
@@ -129,6 +137,8 @@ lib/seed7/lib/wrinum.s7i
lib/seed7/lib/xml_ent.s7i
lib/seed7/lib/xmldom.s7i
lib/seed7/lib/zip.s7i
+man/man1/s7.1.gz
+man/man1/s7c.1.gz
@dirrm lib/seed7/lib
@dirrm lib/seed7/bin
@dirrm lib/seed7