aboutsummaryrefslogtreecommitdiffstats
path: root/lang/smalltalk/Makefile
diff options
context:
space:
mode:
authorjraynard <jraynard@FreeBSD.org>1996-06-06 01:35:13 +0800
committerjraynard <jraynard@FreeBSD.org>1996-06-06 01:35:13 +0800
commit58bbb3d88518474b5421f042214f1e16c203b3b1 (patch)
treee371ddb304c48b7a130684fd285cf67383eb4d31 /lang/smalltalk/Makefile
parent61edf52bc03a4f55d8c2e27e84ca42e2c5d89cfb (diff)
downloadfreebsd-ports-gnome-58bbb3d88518474b5421f042214f1e16c203b3b1.tar.gz
freebsd-ports-gnome-58bbb3d88518474b5421f042214f1e16c203b3b1.tar.zst
freebsd-ports-gnome-58bbb3d88518474b5421f042214f1e16c203b3b1.zip
Made port NO_PACKAGE.
Removed CFLAGS line which didn't appear to do anything. Minor changes to message printed out at install time.
Diffstat (limited to 'lang/smalltalk/Makefile')
-rw-r--r--lang/smalltalk/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 651e7f360df6..12b188563e39 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -3,7 +3,7 @@
# Date created: 09 Feb 1995
# Whom: gpalmer
#
-# $Id: Makefile,v 1.7 1995/11/22 13:13:16 asami Exp $
+# $Id: Makefile,v 1.8 1996/06/03 00:27:35 jraynard Exp $
#
DISTNAME= smalltalk-1.1.1
@@ -13,6 +13,7 @@ MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
MAINTAINER= jraynard@FreeBSD.ORG
IS_INTERACTIVE= yes
+NO_PACKAGE=yes
pre-configure:
@cp ${FILESDIR}/m-fbsd-2.h ${WRKSRC}/config/m-fbsd-2.h
@@ -23,26 +24,27 @@ do-build:
if [ -d ${X11BASE} ]; then (cd ${WRKSRC}/stix; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET}; cp mst *.st ${WRKSRC}); else (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET}); fi;
do-install:
- @echo "Installing Smalltalk interpreter and method definitions..."
+ @echo "Installing method definitions..."
@ if [ ! -d ${PREFIX}/lib/smalltalk ]; then mkdir -p ${PREFIX}/lib/smalltalk; fi
@(cd ${WRKSRC}; cp *.st ${PREFIX}/lib/smalltalk)
@(cd ${PREFIX}/lib/smalltalk ; chmod +r *.st)
@echo
@echo
- @echo
@echo "To complete the installation of GNU Smalltalk, do"
@echo " cd ${WRKSRC}; ./mst -iV"
@echo "to build the image and test the interpreter."
@echo
@echo "When you are satisfied everything works, do Control-D to quit"
@echo "(this will give a parse error, which can be safely ignored)"
- @echo "followed by cp mst ${PREFIX}/bin"
+ @echo "followed by 'cp mst ${PREFIX}/bin'."
@echo
@echo "Finally, if Emacs is installed, you may also wish to copy the"
- @echo "st.el file to the Emacs Lisp directory. This will enable you to"
- @echo "configure Emacs for Interactor mode."
+ @echo "st*.el files to the Emacs Lisp directory. This will enable you"
+ @echo "to configure Emacs for Interactor mode."
@echo
- @echo "Please read the file mst.texinfo for more information."
+ @echo ">>Please read the file"
+ @echo "${WRKSRC}/mst.texinfo"
+ @echo "for more information.<<"
@echo
.include <bsd.port.mk>