aboutsummaryrefslogtreecommitdiffstats
path: root/lang/smalltalk/Makefile
diff options
context:
space:
mode:
authorjraynard <jraynard@FreeBSD.org>1997-11-29 22:15:44 +0800
committerjraynard <jraynard@FreeBSD.org>1997-11-29 22:15:44 +0800
commita705c3f8fdac312ea585a64bae43e6c7bf7b99ab (patch)
tree133259d8b1e9240012c36306e76bf809a1332bb3 /lang/smalltalk/Makefile
parent6c3eb967354903d5cde6ff8286578689470036b7 (diff)
downloadfreebsd-ports-gnome-a705c3f8fdac312ea585a64bae43e6c7bf7b99ab.tar.gz
freebsd-ports-gnome-a705c3f8fdac312ea585a64bae43e6c7bf7b99ab.tar.zst
freebsd-ports-gnome-a705c3f8fdac312ea585a64bae43e6c7bf7b99ab.zip
Update to version 1.1.5 of GNU Smalltalk.
Diffstat (limited to 'lang/smalltalk/Makefile')
-rw-r--r--lang/smalltalk/Makefile39
1 files changed, 21 insertions, 18 deletions
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index af109d76c5f5..5f451547292b 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -3,25 +3,26 @@
# Date created: 09 Feb 1995
# Whom: gpalmer
#
-# $Id: Makefile,v 1.12 1996/12/07 17:58:22 max Exp $
+# $Id: Makefile,v 1.13 1996/12/08 01:44:46 max Exp $
#
-DISTNAME= smalltalk-1.1.1
+DISTNAME= smalltalk-1.1.5
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MAINTAINER= jraynard@FreeBSD.ORG
+BUILD_DEPENDS= ${PREFIX}/lib/libgdbm.a:${PORTSDIR}/databases/gdbm
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-optimize --with-readline
+
IS_INTERACTIVE= yes
NO_PACKAGE= "Installation requires interaction"
-pre-configure:
- @${CP} ${FILESDIR}/m-fbsd-2.h ${WRKSRC}/config/m-fbsd-2.h
- @(cd ${WRKSRC} ; ./config.mst fbsd-2)
- @${TOUCH} ${TOUCH_FLAGS} ${CONFIGURE_COOKIE}
-
-do-build:
- if [ -d ${X11BASE} ]; then (cd ${WRKSRC}/stix; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET}; ${CP} mst *.st ${WRKSRC}); else (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET}); fi;
+# For some reason configure doesn't set this up properly and my feeble
+# brain can't see how to fix it.
+CFLAGS+= -I${X11BASE}/include
do-install:
@echo "Installing method definitions..."
@@ -29,21 +30,23 @@ do-install:
@(cd ${WRKSRC}; ${CP} *.st ${PREFIX}/lib/smalltalk)
@(cd ${PREFIX}/lib/smalltalk ; chmod +r *.st)
@echo
- @echo
@echo "To complete the installation of GNU Smalltalk, do"
- @echo " cd ${WRKSRC}; ./mst -iV"
- @echo "to build the image and test the interpreter."
+ @echo " cd ${WRKSRC};"
+ @echo "./gst -iV"
+ @echo "to test the interpreter and create the image."
@echo
@echo "When you are satisfied everything works, do Control-D to quit"
- @echo "(this will give a parse error, which can be safely ignored)"
- @echo "followed by 'cp mst ${PREFIX}/bin'."
+ @echo "followed by"
+ @echo "cp gst ${PREFIX}/bin"
+ @echo "cp gst.im ${PREFIX}/lib/smalltalk"
+ @echo "to install the interpreter and image."
@echo
- @echo "Finally, if Emacs is installed, you may also wish to copy the"
- @echo "st*.el files to the Emacs Lisp directory. This will enable you"
+ @echo "If Emacs is installed, you may also wish to copy the"
+ @echo "*st.el files to the Emacs Lisp directory. This will enable you"
@echo "to configure Emacs for Interactor mode."
@echo
- @echo ">>Please read the file"
- @echo "${WRKSRC}/mst.texinfo"
+ @echo ">>Please read the file"
+ @echo "${WRKSRC}/info/gst.txi"
@echo "for more information.<<"
@echo