aboutsummaryrefslogtreecommitdiffstats
path: root/lang/smalltalk
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-22 00:20:23 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-22 00:20:23 +0800
commitc33ba7a93beedb65065750f6fa125277fa1f1b51 (patch)
tree4b05f56b4bd74a7dbee4fca4ad8a61f8aa5e5bfe /lang/smalltalk
parent47ed91c6adc3291426fa5760230286c31b9dc8be (diff)
downloadfreebsd-ports-gnome-c33ba7a93beedb65065750f6fa125277fa1f1b51.tar.gz
freebsd-ports-gnome-c33ba7a93beedb65065750f6fa125277fa1f1b51.tar.zst
freebsd-ports-gnome-c33ba7a93beedb65065750f6fa125277fa1f1b51.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39605 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'lang/smalltalk')
-rw-r--r--lang/smalltalk/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index de76608b9c5f..c55660d1c4f9 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -14,6 +14,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a/a/}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO='makeinfo --no-split'
@@ -35,8 +36,8 @@ post-extract:
@${RM} -f ${WRKSRC}/doc/gst.info*
pre-patch:
- @${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${PERL} -pi -e \
- 's| -release \$$\(VERSION\)| -avoid-version|g'
- @${PERL} -pi -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/libltdl/ltdl.c
+ @${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e \
+ 's| -release \$$(VERSION)| -avoid-version|g'
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/libltdl/ltdl.c
.include <bsd.port.mk>