aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spidermonkey/files
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-09 05:31:22 +0800
committeredwin <edwin@FreeBSD.org>2006-01-09 05:31:22 +0800
commitdb9b120d0c4a0795e54f843b0927725dfaff053a (patch)
tree3c4c27b8b12e5f216219c5689acb99cc5c4f288d /lang/spidermonkey/files
parent73f5aca6efbcb74092bbccea498bd471bb58e994 (diff)
downloadfreebsd-ports-gnome-db9b120d0c4a0795e54f843b0927725dfaff053a.tar.gz
freebsd-ports-gnome-db9b120d0c4a0795e54f843b0927725dfaff053a.tar.zst
freebsd-ports-gnome-db9b120d0c4a0795e54f843b0927725dfaff053a.zip
Spidermonkey version update to 1.5 with fixes for ia64/amd64
Update source to spidermonkey 1.5 and patched (much thanks to Anish Mistry) to fix compilation problems under amd64 (and presumably ia64 too but untested) and to make the build thread-safe. PR: ports/91522 Submitted by: Dan Rench <citric@cubicone.tmetic.com>
Diffstat (limited to 'lang/spidermonkey/files')
-rw-r--r--lang/spidermonkey/files/patch-config17
-rw-r--r--lang/spidermonkey/files/patch-warnings24
2 files changed, 11 insertions, 30 deletions
diff --git a/lang/spidermonkey/files/patch-config b/lang/spidermonkey/files/patch-config
index 0b3e7fc887ac..a1f5484eeba6 100644
--- a/lang/spidermonkey/files/patch-config
+++ b/lang/spidermonkey/files/patch-config
@@ -27,9 +27,10 @@
+ $(CC) -o $@ $(CFLAGS) $(PROG_OBJS) -L$(OBJDIR) -ljs $(LDFLAGS) $(OTHER_LIBS) \
$(PROG_LIBS)
endif
---- config/Linux_All.mk Thu May 15 20:21:08 2003
-+++ config/Linux_All.mk Wed Aug 10 23:46:05 2005
-@@ -37,7 +37,7 @@
+--- config/Linux_All.mk.orig Tue May 10 15:53:44 2005
++++ config/Linux_All.mk Sat Dec 10 21:17:45 2005
+@@ -41,9 +41,9 @@
+ # Config for all versions of Linux
#
-CC = gcc
@@ -40,14 +41,18 @@
+CFLAGS += -Wall -Werror # XXX do these work with non-gcc and non-icc?
OS_CFLAGS = -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DHAVE_LOCALTIME_R
-@@ -70,5 +70,5 @@
+ RANLIB = echo
+@@ -74,7 +74,7 @@
+
GFX_ARCH = x
-OS_LIBS = -lm -lc
+OS_LIBS = -lm
ASFLAGS += -x assembler-with-cpp
-@@ -84,15 +84,11 @@
+
+@@ -88,16 +88,12 @@
+ endif
# Use the editline library to provide line-editing support.
-JS_EDITLINE = 1
@@ -56,7 +61,7 @@
-ifeq ($(CPU_ARCH),x86_64)
-# Use VA_COPY() standard macro on x86-64
-# FIXME: better use it everywhere
- OS_CFLAGS += -DHAVE_VA_COPY
+ OS_CFLAGS += -DHAVE_VA_COPY -DVA_COPY=va_copy
-endif
-ifeq ($(CPU_ARCH),x86_64)
diff --git a/lang/spidermonkey/files/patch-warnings b/lang/spidermonkey/files/patch-warnings
index 70d717cae5d4..f7877652ac02 100644
--- a/lang/spidermonkey/files/patch-warnings
+++ b/lang/spidermonkey/files/patch-warnings
@@ -227,13 +227,6 @@
+ sharpid = (jsatomid)(uintptr_t)he->value;
if (sharpid == 0) {
*sp = NULL;
-@@ -1104,5 +1104,5 @@
- const JSResolvingKey *key = (const JSResolvingKey *)ptr;
-
-- return ((JSDHashNumber)key->obj >> JSVAL_TAGBITS) ^ key->id;
-+ return ((JSDHashNumber)(uintptr_t)key->obj >> JSVAL_TAGBITS) ^ key->id;
- }
-
--- jsopcode.c Thu Jun 10 00:33:52 2004
+++ jsopcode.c Sat Aug 6 19:13:50 2005
@@ -181,5 +181,5 @@
@@ -254,23 +247,6 @@
+ fprintf(fp, "\n\t%d: %td", i, off);
pc2 += jmplen;
}
-@@ -230,5 +230,5 @@
- {
- jsbytecode *pc2;
-- jsint npairs;
-+ int npairs;
-
- jmplen = (type == JOF_LOOKUPSWITCH) ? JUMP_OFFSET_LEN
-@@ -237,7 +237,7 @@
- off = GetJumpOffset(pc, pc2);
- pc2 += jmplen;
-- npairs = (jsint) GET_ATOM_INDEX(pc2);
-+ npairs = GET_ATOM_INDEX(pc2);
- pc2 += ATOM_INDEX_LEN;
-- fprintf(fp, " offset %d npairs %u", off, (uintN) npairs);
-+ fprintf(fp, " offset %td npairs %d", off, npairs);
- while (npairs) {
- atom = GET_ATOM(cx, script, pc2);
@@ -253,5 +253,5 @@
if (!cstr)
return 0;