aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spidermonkey
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-01-30 02:05:55 +0800
committerpav <pav@FreeBSD.org>2006-01-30 02:05:55 +0800
commit47ed7a8f56304f7e7a05e6abfb93c7862faca2a9 (patch)
tree82e207c028dbe4cd9497867ca972d0da82effd8f /lang/spidermonkey
parent7b85b0b4986a9db5ea9050a4b94284c9f69608ec (diff)
downloadfreebsd-ports-gnome-47ed7a8f56304f7e7a05e6abfb93c7862faca2a9.tar.gz
freebsd-ports-gnome-47ed7a8f56304f7e7a05e6abfb93c7862faca2a9.tar.zst
freebsd-ports-gnome-47ed7a8f56304f7e7a05e6abfb93c7862faca2a9.zip
- Fix on 64-bit arches
PR: ports/92396 Submitted by: Dan Rench <citric@cubicone.tmetic.com> (maintainer)
Diffstat (limited to 'lang/spidermonkey')
-rw-r--r--lang/spidermonkey/Makefile4
-rw-r--r--lang/spidermonkey/files/patch-jscntxt.c11
-rw-r--r--lang/spidermonkey/files/patch-jslock.c11
-rw-r--r--lang/spidermonkey/files/patch-jsopcode.c11
-rw-r--r--lang/spidermonkey/files/patch-jstypes.h22
5 files changed, 55 insertions, 4 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index d53cc60c5f3a..7312487e8a63 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -70,10 +70,6 @@ test:
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= Does not compile on !i386
-.endif
-
.if ${OSVERSION} < 500000
BROKEN= Does not compile on FreeBSD 4.x
.endif
diff --git a/lang/spidermonkey/files/patch-jscntxt.c b/lang/spidermonkey/files/patch-jscntxt.c
new file mode 100644
index 000000000000..91861d195eab
--- /dev/null
+++ b/lang/spidermonkey/files/patch-jscntxt.c
@@ -0,0 +1,11 @@
+--- jscntxt.c.orig Sat Jan 14 01:57:13 2006
++++ jscntxt.c Sat Jan 14 02:14:51 2006
+@@ -334,7 +334,7 @@
+ {
+ const JSResolvingKey *key = (const JSResolvingKey *)ptr;
+
+- return ((JSDHashNumber)key->obj >> JSVAL_TAGBITS) ^ key->id;
++ return ((JSDHashNumber)JS_PTR_TO_UINT32(key->obj) >> JSVAL_TAGBITS) ^ key->id;
+ }
+
+ JS_PUBLIC_API(JSBool)
diff --git a/lang/spidermonkey/files/patch-jslock.c b/lang/spidermonkey/files/patch-jslock.c
new file mode 100644
index 000000000000..540248a105c6
--- /dev/null
+++ b/lang/spidermonkey/files/patch-jslock.c
@@ -0,0 +1,11 @@
+--- jslock.c.orig Sat Jan 14 02:20:18 2006
++++ jslock.c Sat Jan 14 02:22:17 2006
+@@ -193,7 +193,9 @@
+ #endif
+ }
+
++#ifndef NSPR_LOCK
+ static void js_Dequeue(JSThinLock *);
++#endif
+
+ #ifdef DEBUG_SCOPE_COUNT
diff --git a/lang/spidermonkey/files/patch-jsopcode.c b/lang/spidermonkey/files/patch-jsopcode.c
new file mode 100644
index 000000000000..b1fdad8592c5
--- /dev/null
+++ b/lang/spidermonkey/files/patch-jsopcode.c
@@ -0,0 +1,11 @@
+--- jsopcode.c.orig Sun Aug 29 18:00:24 2004
++++ jsopcode.c Sat Jan 14 02:26:07 2006
+@@ -239,7 +239,7 @@
+ pc2 += jmplen;
+ npairs = GET_ATOM_INDEX(pc2);
+ pc2 += ATOM_INDEX_LEN;
+- fprintf(fp, " offset %d npairs %u", off, (uintN) npairs);
++ fprintf(fp, " offset %td npairs %u", off, (uintN) npairs);
+ while (npairs) {
+ atom = GET_ATOM(cx, script, pc2);
+ pc2 += ATOM_INDEX_LEN;
diff --git a/lang/spidermonkey/files/patch-jstypes.h b/lang/spidermonkey/files/patch-jstypes.h
new file mode 100644
index 000000000000..bb80c3e6e9ee
--- /dev/null
+++ b/lang/spidermonkey/files/patch-jstypes.h
@@ -0,0 +1,22 @@
+--- jstypes.h.orig Sat Nov 15 00:11:04 2003
++++ jstypes.h Sat Jan 14 02:17:40 2006
+@@ -203,6 +203,19 @@
+ #define JS_BITMASK(n) (JS_BIT(n) - 1)
+
+ /***********************************************************************
++** MACROS: JS_PTR_TO_INT32
++** JS_PTR_TO_UINT32
++** JS_INT32_TO_PTR
++** JS_UINT32_TO_PTR
++** DESCRIPTION:
++** Integer to pointer and pointer to integer conversion macros.
++***********************************************************************/
++#define JS_PTR_TO_INT32(x) ((jsint)((char *)(x) - (char *)0))
++#define JS_PTR_TO_UINT32(x) ((jsuint)((char *)(x) - (char *)0))
++#define JS_INT32_TO_PTR(x) ((void *)((char *)0 + (jsint)(x)))
++#define JS_UINT32_TO_PTR(x) ((void *)((char *)0 + (jsuint)(x)))
++
++/***********************************************************************
+ ** MACROS: JS_HOWMANY
+ ** JS_ROUNDUP
+ ** JS_MIN