aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spidermonkey
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-08-06 02:19:38 +0800
committersat <sat@FreeBSD.org>2006-08-06 02:19:38 +0800
commit65761b2c24769933051644a8e248fe23eb7b7b8b (patch)
tree7e0a606ac32868466ec95dfdc6914738ea3e67a8 /lang/spidermonkey
parent3dfe7699710fe61b8ce10b35273952b4ca84644b (diff)
downloadfreebsd-ports-gnome-65761b2c24769933051644a8e248fe23eb7b7b8b.tar.gz
freebsd-ports-gnome-65761b2c24769933051644a8e248fe23eb7b7b8b.tar.zst
freebsd-ports-gnome-65761b2c24769933051644a8e248fe23eb7b7b8b.zip
- Install a versioned lib
Approved by: citric@cubicone.tmetic.com (maintainer timeout, 16 days)
Diffstat (limited to 'lang/spidermonkey')
-rw-r--r--lang/spidermonkey/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index 320866b6d32b..55e5075746b1 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -55,7 +55,7 @@ INSTALLS_SHLIB= YES
SRC_DIR= js/src
JSH= jsapi.h jsautocfg.h jscompat.h jslong.h jsosdep.h jsotypes.h jspubtd.h jstypes.h \
jsstr.h jshash.h jsprvtd.h
-PLIST_FILES= bin/js lib/libjs.so ${JSH:S,^,include/,}
+PLIST_FILES= bin/js lib/libjs.so lib/libjs.so.1 ${JSH:S,^,include/,}
WRKSRC= ${WRKDIR}/${SRC_DIR}
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
--exclude js/jsd \
@@ -86,6 +86,7 @@ do-install:
${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/libjs.so \
${PREFIX}/lib
+ ${LN} -sf ${PREFIX}/lib/libjs.so ${PREFIX}/lib/libjs.so.1
${CP} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/jsautocfg.h ${WRKSRC}
@${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} ${PREFIX}/include/