aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spidermonkey
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-10-31 00:46:18 +0800
committermi <mi@FreeBSD.org>2006-10-31 00:46:18 +0800
commitb4ce22494f25c0fbdcb821a7961dd346ced390e0 (patch)
tree451c352c20b7ec486ee3b43a887028e3dced89e8 /lang/spidermonkey
parent3ee8e69eec852d8266ac391e13f52a49488ec0e4 (diff)
downloadfreebsd-ports-gnome-b4ce22494f25c0fbdcb821a7961dd346ced390e0.tar.gz
freebsd-ports-gnome-b4ce22494f25c0fbdcb821a7961dd346ced390e0.tar.zst
freebsd-ports-gnome-b4ce22494f25c0fbdcb821a7961dd346ced390e0.zip
Make SpiderMonkey build with thread-support regardless of whether or not
the post-build self-testing is enabled. The self-test was on by default until March, which hid the problem... Take pointy-hat. Noticed by: Anish Mistry Approved by: portmgr (erwin)
Diffstat (limited to 'lang/spidermonkey')
-rw-r--r--lang/spidermonkey/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index 017e7f121601..28e39fac4b1d 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -6,7 +6,7 @@
PORTNAME= spidermonkey
DISTVERSION= 1.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= MOZILLA:src,older
MASTER_SITE_SUBDIR= js/:src js/older-packages/:older
@@ -18,6 +18,11 @@ COMMENT= A standalone JavaScript interpreter from the Mozilla project
CONFLICTS= njs-[0-9]*
+LIB_DEPENDS= nspr4.1:${PORTSDIR}/devel/nspr
+MAKE_ARGS+= JS_THREADSAFE=YES \
+ PROG_LIBS="-lreadline -ltermcap -lm ${PTHREAD_LIBS}" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CFLAGS+= -I${LOCALBASE}/include/nspr
.if defined(WITH_TEST)
USE_PERL5_BUILD=test harness
PATCHFILES= spidermonkey-patch-tests-ecma.bz2 \
@@ -25,11 +30,6 @@ PATCHFILES= spidermonkey-patch-tests-ecma.bz2 \
spidermonkey-patch-tests-js.bz2
PATCH_SITES= http://virtual-estates.net/~mi/port-stuff/
BUILD_DEPENDS+= ${SITE_PERL}/Getopt/Mixed.pm:${PORTSDIR}/devel/p5-Getopt-Mixed
-LIB_DEPENDS= nspr4.1:${PORTSDIR}/devel/nspr
-MAKE_ARGS+= JS_THREADSAFE=YES \
- PROG_LIBS="-lreadline -ltermcap -lm ${PTHREAD_LIBS}" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CFLAGS+= -I${LOCALBASE}/include/nspr
DISTFILES+= js-tests-20021118${EXTRACT_SUFX}:older
post-build: test
@@ -43,7 +43,6 @@ post-patch:
js1_2/function/function-001-n.js \
js1_3/Script/function-001-n.js \
js1_5/Array/regress-101964.js
-
.endif
USE_GMAKE= YES