aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spidermonkey
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-06-24 03:47:12 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-06-24 03:47:12 +0800
commitc1cd8c18cf22d76862170071684fe80c9dbf8323 (patch)
treed8f9239616c199731c4732cbca0aed4f6ecc9a8c /lang/spidermonkey
parent8ea575ffe98e33c782bba8de6bd1f49de47ecb83 (diff)
downloadfreebsd-ports-gnome-c1cd8c18cf22d76862170071684fe80c9dbf8323.tar.gz
freebsd-ports-gnome-c1cd8c18cf22d76862170071684fe80c9dbf8323.tar.zst
freebsd-ports-gnome-c1cd8c18cf22d76862170071684fe80c9dbf8323.zip
- Fix pkg-plist (install all header files)
PR: ports/134770 Submitted by: Dan Rench <citric@cubicone.tmetic.com> Approved by: maintainer
Diffstat (limited to 'lang/spidermonkey')
-rw-r--r--lang/spidermonkey/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index af963aefcd3b..d1ecbf6a6b12 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -7,11 +7,8 @@
PORTNAME= spidermonkey
DISTVERSION= 1.7.0
CATEGORIES= lang
-MASTER_SITES= http://ftp.mozilla.org/pub/mozilla.org/js/ \
- http://ftp.belnet.be/mirrors/ftp.mozilla.org/js/ \
- http://gentoo.netnitco.net/distfiles/ \
- http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/ \
- ftp://ftp.mozilla.org/pub/mozilla.org/js/
+MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
+MASTER_SITE_SUBDIR= js
DISTNAME= js-${DISTVERSION}
MAINTAINER= citric@cubicone.tmetic.com
@@ -32,9 +29,16 @@ ALL_TARGET= ${OPSYS}`${UNAME} -r`_DBG.OBJ/js
MAKE_ENV+= CCC="${CXX}"
USE_LDCONFIG= yes
SRC_DIR= js/src
-JSH= jsapi.h jsautocfg.h jsconfig.h jscompat.h jslong.h jsosdep.h \
- jsotypes.h jspubtd.h jstypes.h jsstr.h jshash.h jsprvtd.h \
+
+JSH= jsapi.h jsarena.h jsarray.h jsatom.h jsautocfg.h jsbool.h \
+ jsclist.h jscntxt.h jscompat.h jsconfig.h jsdate.h jsdhash.h \
+ jsdtoa.h jsemit.h jsexn.h jsfun.h jsgc.h jshash.h jsinterp.h \
+ jsiter.h jslibmath.h jslock.h jslong.h jsmath.h jsnum.h jsobj.h \
+ jsopcode.h jsosdep.h jsotypes.h jsparse.h jsprvtd.h jspubtd.h \
+ jsregexp.h jsscan.h jsscope.h jsscript.h jsstr.h jstypes.h \
+ jsxdrapi.h jsxml.h \
jsproto.tbl
+
PLIST_FILES= bin/js lib/libjs.so lib/libjs.so.1 ${JSH:S,^,include/,}
WRKSRC= ${WRKDIR}/${SRC_DIR}
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \