aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tcbasic
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-04-18 05:01:44 +0800
committerpawel <pawel@FreeBSD.org>2015-04-18 05:01:44 +0800
commit4dc507ed03c55a36fe5a79e2cb7c55089ea12d52 (patch)
tree8cd71de304114d2f3c32567c87ea056259316003 /lang/tcbasic
parent50e870e2e5abc88ff2d0eeabb10bd72c8fad555d (diff)
downloadfreebsd-ports-gnome-4dc507ed03c55a36fe5a79e2cb7c55089ea12d52.tar.gz
freebsd-ports-gnome-4dc507ed03c55a36fe5a79e2cb7c55089ea12d52.tar.zst
freebsd-ports-gnome-4dc507ed03c55a36fe5a79e2cb7c55089ea12d52.zip
tcbasic implements a small subset of BASIC known as Tiny BASIC.
It provides the following statements and commands: INPUT, PRINT, LET, GOTO, GOSUB, RETURN, IF, END, CLEAR, LIST, and RUN. Integer arithmetic is supported, and strings may be PRINTed. A built-in RND(n) function provides random numbers. The small size of the language make it easy to learn and master while providing all of the building blocks needed to develop many interesting programs. tcbasic runs on a variety of platforms and aims to be as portable as possible. WWW: https://github.com/tcort/tcbasic PR: 197938 Submitted by: Thomas Cort <linuxgeek@gmail.com>
Diffstat (limited to 'lang/tcbasic')
-rw-r--r--lang/tcbasic/Makefile20
-rw-r--r--lang/tcbasic/distinfo2
-rw-r--r--lang/tcbasic/pkg-descr12
3 files changed, 34 insertions, 0 deletions
diff --git a/lang/tcbasic/Makefile b/lang/tcbasic/Makefile
new file mode 100644
index 000000000000..3880db54874e
--- /dev/null
+++ b/lang/tcbasic/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= tcbasic
+PORTVERSION= 2.0.0
+CATEGORIES= lang
+
+MAINTAINER= linuxgeek@gmail.com
+COMMENT= Small BASIC Interpreter written in C
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= tcort
+GH_TAGNAME= v${PORTVERSION}
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/tcbasic man/man1/tcbasic.1.gz
+
+.include <bsd.port.mk>
diff --git a/lang/tcbasic/distinfo b/lang/tcbasic/distinfo
new file mode 100644
index 000000000000..afd06b0568eb
--- /dev/null
+++ b/lang/tcbasic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tcort-tcbasic-2.0.0-v2.0.0_GH0.tar.gz) = a5eec00b8598a9887141d7a407918c93ded82fc24fe07714a6d0503a34e859e8
+SIZE (tcort-tcbasic-2.0.0-v2.0.0_GH0.tar.gz) = 31724
diff --git a/lang/tcbasic/pkg-descr b/lang/tcbasic/pkg-descr
new file mode 100644
index 000000000000..85f112b78045
--- /dev/null
+++ b/lang/tcbasic/pkg-descr
@@ -0,0 +1,12 @@
+tcbasic implements a small subset of BASIC known as Tiny BASIC.
+It provides the following statements and commands: INPUT, PRINT,
+LET, GOTO, GOSUB, RETURN, IF, END, CLEAR, LIST, and RUN. Integer
+arithmetic is supported, and strings may be PRINTed. A built-in
+RND(n) function provides random numbers.
+
+The small size of the language make it easy to learn and master
+while providing all of the building blocks needed to develop many
+interesting programs. tcbasic runs on a variety of platforms and
+aims to be as portable as possible.
+
+WWW: https://github.com/tcort/tcbasic