aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tcl80
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-13 18:31:46 +0800
committermiwi <miwi@FreeBSD.org>2007-03-13 18:31:46 +0800
commit499e73a112a5b3f175e35fe3502f23aa8525e2f9 (patch)
tree51ec1253aec9b1e37b1237b742b566d54c669d3f /lang/tcl80
parentfb6359eddd21b3d7fed535248a9b977eda346e43 (diff)
downloadfreebsd-ports-gnome-499e73a112a5b3f175e35fe3502f23aa8525e2f9.tar.gz
freebsd-ports-gnome-499e73a112a5b3f175e35fe3502f23aa8525e2f9.tar.zst
freebsd-ports-gnome-499e73a112a5b3f175e35fe3502f23aa8525e2f9.zip
- Adds TCL80_MAN and TCLSH_WRAPPER to OPTIONS
- Removes pseudo-installation of tclsh in favour of new lang/tcl-tk-wrapper port - Adds support for NO_INSTALL_MANPAGES knob - Pass maintainership to submitter - Bump PORTREVISION PR: 110233 Submitted by: Martin Matuska <martin@matuska.org>
Diffstat (limited to 'lang/tcl80')
-rw-r--r--lang/tcl80/Makefile26
-rw-r--r--lang/tcl80/files/patch-aa13
-rw-r--r--lang/tcl80/pkg-deinstall.tclsh22
-rw-r--r--lang/tcl80/pkg-install.tclsh35
4 files changed, 23 insertions, 73 deletions
diff --git a/lang/tcl80/Makefile b/lang/tcl80/Makefile
index 62f0705edf63..dfe69e4329c3 100644
--- a/lang/tcl80/Makefile
+++ b/lang/tcl80/Makefile
@@ -7,13 +7,13 @@
PORTNAME= tcl
PORTVERSION= 8.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang tcl80
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR=tcl8_0
DISTNAME= ${PORTNAME}${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= martin@matuska.org
COMMENT= Tool Command Language
NO_LATEST_LINK= yes
@@ -22,29 +22,29 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
-PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
-PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
SHLIB_MAJOR= 1
SHLIB_MINOR= 5
MAKEFILE= makefile
TCL_LIB= libtcl80.so
+OPTIONS= TCL80_MAN "Install tcl 8.0 manpages" off \
+ TCLSH_WRAPPER "Require tclsh wrapper from ports" off
+
.include <bsd.port.pre.mk>
-.if defined(WITH_TCL80_MAN)
-.include "${FILESDIR}/manpages"
+.if defined(WITH_TCLSH_WRAPPER)
+RUN_DEPENDS+= tclsh:${PORTSDIR}/lang/tcl-tk-wrapper
.endif
+.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL80_MAN)
+.include "${FILESDIR}/manpages"
MANCOMPRESSED= yes
+.endif
post-configure:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
@${CP} ${FILESDIR}/makefile ${WRKSRC}
-.if !defined(WITH_TCL80_MAN)
- @${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
- ${WRKSRC}/Makefile
-.endif
pre-build:
@cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} \
@@ -52,10 +52,10 @@ pre-build:
OSVERSION=${OSVERSION}
post-install:
- ${LN} -sf ${TCL_LIB}.${SHLIB_MAJOR} ${PREFIX}/lib/${TCL_LIB}
-.if exists(${PKGINSTALL})
- ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL}
+.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL80_MAN)
+ @cd ${WRKSRC} && ${MAKE} -f Makefile install-man
.endif
+ ${LN} -sf ${TCL_LIB}.${SHLIB_MAJOR} ${PREFIX}/lib/${TCL_LIB}
test:
cd ${WRKSRC} && ${MAKE} test
diff --git a/lang/tcl80/files/patch-aa b/lang/tcl80/files/patch-aa
index 8272d20bcba7..5141e7e7fb86 100644
--- a/lang/tcl80/files/patch-aa
+++ b/lang/tcl80/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.in.orig Thu Apr 29 10:26:03 1999
-+++ Makefile.in Thu Apr 29 10:33:07 1999
+--- Makefile.in.orig Tue Mar 9 07:51:26 1999
++++ Makefile.in Mon Mar 12 16:32:22 2007
@@ -55,7 +55,9 @@
BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
@@ -43,7 +43,14 @@
# Make target which outputs the list of the .o contained in the Tcl lib
# usefull to build a single big shared library containing Tcl and other
# extensions. used for the Tcl Plugin. -- dl
-@@ -433,7 +441,7 @@
+@@ -427,13 +435,13 @@
+ cd dltest; if test -f configure; then ./configure; else \
+ $(DLTEST_DIR)/configure; fi
+
+-install: install-binaries install-libraries install-man
++install: install-binaries install-libraries
+
+ # Note: before running ranlib below, must cd to target directory because
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
diff --git a/lang/tcl80/pkg-deinstall.tclsh b/lang/tcl80/pkg-deinstall.tclsh
deleted file mode 100644
index c48dc863cf43..000000000000
--- a/lang/tcl80/pkg-deinstall.tclsh
+++ /dev/null
@@ -1,22 +0,0 @@
-#! /bin/sh
-#
-# Remove the ${PREFIX}/bin/tclsh script that gets installed by INSTALL.tclsh
-# if we are the last tclsh installation to be pkg_delete'd.
-#
-# $FreeBSD$
-#
-
-#
-# Explicitly listing /usr/X11R6/bin here is debatable.
-#
-BINDIR="${PKG_PREFIX}/bin /usr/X11R6/bin"
-TCLSH=${PKG_PREFIX}/bin/tclsh
-
-tclshs=$(/bin/ls ${BINDIR} 2> /dev/null | \
- egrep '^(i?tclsh[0-9]+\.[0-9]+(\_r)?([a-z][a-z])?)|otclsh$')
-
-if [ "$tclshs" = "" -a -f ${TCLSH} ] && \
- (head -3 ${TCLSH} | grep awieYJFnsuILOnfsYEW) > /dev/null 2>&1
-then
- rm -f ${PKG_PREFIX}/bin/tclsh
-fi
diff --git a/lang/tcl80/pkg-install.tclsh b/lang/tcl80/pkg-install.tclsh
deleted file mode 100644
index 3b808e2b500f..000000000000
--- a/lang/tcl80/pkg-install.tclsh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-# The user may have a tclsh they want to preserve
-ver=`grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/tclsh 2> /dev/null \
- | sed -e 's/.*\*\*//'`
-if [ ! -e ${PKG_PREFIX}/bin/tclsh ] || [ "$ver" != "" -a "$ver" -lt 002 ]
-then
- [ -f ${PKG_PREFIX}/bin/tclsh ] && chmod u+w ${PKG_PREFIX}/bin/tclsh
-
- mkdir -p ${PKG_PREFIX}/bin
- cat > ${PKG_PREFIX}/bin/tclsh <<'EOF'
-#!/bin/sh
-# Installed by ports system. id: awieYJFnsuILOnfsYEW**002
-#
-# $FreeBSD$
-#
-
-(
-echo "In FreeBSD, tclsh is named with a version number. This is because"
-echo "different versions of tclsh are not compatible with each other and"
-echo "they can not all be called \"tclsh\"! You may need multiple versions"
-echo "installed because a given port may depend on a specific version."
-echo
-echo "On your system, tclsh is installed under at least the following names:"
-echo
-for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^(i?tclsh[0-9]+\.[0-9]+(\_r)?([a-z][a-z])?)|otclsh$')
-do
- echo $name
-done
-[ "$name" = "" ] && echo "No tclsh installations found, sorry."
-) 1>&2
-exit 1
-EOF
- chmod 555 ${PKG_PREFIX}/bin/tclsh
-fi