aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tcl80
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /lang/tcl80
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'lang/tcl80')
-rw-r--r--lang/tcl80/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/lang/tcl80/Makefile b/lang/tcl80/Makefile
index 873790850830..44a06426e998 100644
--- a/lang/tcl80/Makefile
+++ b/lang/tcl80/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.7 1998/07/27 21:14:46 hoek Exp $
+# $Id: Makefile,v 1.8 1998/09/17 22:30:01 steve Exp $
#
DISTNAME= tcl8.0p2
@@ -17,12 +17,21 @@ WRKSRC= ${WRKDIR}/tcl8.0/unix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
+EXTRA_PKG_ARGS= -i ${PKGDIR}/INSTALL.tclsh
SHLIB_MAJOR= 1
SHLIB_MINOR= 2
MAKEFILE= makefile
TCL_LIB= libtcl80.so
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+TCL_LIB_FILE= ${TCL_LIB}.${SHLIB_MAJOR}
+.else
+TCL_LIB_FILE= ${TCL_LIB}.${SHLIB_MAJOR}.${SHLIB_MINOR}
+.endif
+
post-configure:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
@${CP} ${FILESDIR}/makefile ${WRKSRC}
@@ -41,12 +50,4 @@ post-install:
test:
cd ${WRKSRC} && ${MAKE} test
-.include <bsd.port.mk>
-
-PKG_ARGS+= -i ${PKGDIR}/INSTALL.tclsh
-
-.if ${PORTOBJFORMAT} == "elf"
-TCL_LIB_FILE= ${TCL_LIB}.${SHLIB_MAJOR}
-.else
-TCL_LIB_FILE= ${TCL_LIB}.${SHLIB_MAJOR}.${SHLIB_MINOR}
-.endif
+.include <bsd.port.post.mk>