aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tcl84/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-03-24 04:29:46 +0800
committerdinoex <dinoex@FreeBSD.org>2003-03-24 04:29:46 +0800
commit6fbccefb1a0d7ea6f34119651272f663e867804b (patch)
tree979c7c54c8c8631024dedfbc837a58a132ce9333 /lang/tcl84/Makefile
parent918d826b1760e1956ebac8a17eff237ec76e9f88 (diff)
downloadfreebsd-ports-gnome-6fbccefb1a0d7ea6f34119651272f663e867804b.tar.gz
freebsd-ports-gnome-6fbccefb1a0d7ea6f34119651272f663e867804b.tar.zst
freebsd-ports-gnome-6fbccefb1a0d7ea6f34119651272f663e867804b.zip
- Update to 8.4.2
- make SOURCE path in tclConfig.sh variable PR: 48574
Diffstat (limited to 'lang/tcl84/Makefile')
-rw-r--r--lang/tcl84/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index 7b80c8c78f3c..ced4e7ea3014 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tcl
-PORTVERSION= 8.4.1
+PORTVERSION= 8.4.2
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -28,6 +28,7 @@ PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
TCL_VER= 8.4
NOPRECIOUSMAKEVARS= Too many _MLINKS for README.html
+USE_REINPLACE= YES
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=84
@@ -588,10 +589,15 @@ PKGNAMESUFFIX?= -threads
USE_REINPLACE= YES
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
.endif
+post-configure:
+ ${REINPLACE_CMD} -e 's=${WRKDIRPREFIX}=$${WRKDIRPREFIX}=' \
+ ${WRKSRC}/tclConfig.sh
+
.include <bsd.port.pre.mk>
post-install: