aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tcl84
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-07-06 04:04:24 +0800
committermi <mi@FreeBSD.org>2006-07-06 04:04:24 +0800
commit9e539a0df004f45a8057ce624dae0d5cc9aee60e (patch)
tree1902c444504635a1400319202dbd3dea3b5d5408 /lang/tcl84
parent43e32924edc0d79c8e68eef818255056b1443ce3 (diff)
downloadfreebsd-ports-gnome-9e539a0df004f45a8057ce624dae0d5cc9aee60e.tar.gz
freebsd-ports-gnome-9e539a0df004f45a8057ce624dae0d5cc9aee60e.tar.zst
freebsd-ports-gnome-9e539a0df004f45a8057ce624dae0d5cc9aee60e.zip
Add check for net.inet.tcp.blackhole and warn users, when it is set, as well
as disable socket.test in this case. Some of the TCL's self-tests attempt to open a socket to (or request http-data from) a "dead" port on the localhost. These tests expect a quick failure, but get a hang, when the blackhole is on. Tests in http.test use a timeout, but some of those in socket.test do not... Pointed out by: confusion on ports@
Diffstat (limited to 'lang/tcl84')
-rw-r--r--lang/tcl84/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index d1981fef50a0..e83c440ee99d 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -612,6 +612,9 @@ pre-configure:
.endif
+# Where the below command fails, there is no need for concern:
+BLACKHOLE!= sysctl -n net.inet.tcp.blackhole
+
post-configure:
${REINPLACE_CMD} \
-e 's|${WRKDIRPREFIX}${.CURDIR}|$${WRKDIRPREFIX}${TCLBASE}|' \
@@ -627,6 +630,14 @@ post-configure:
${WRKSRC}/../doc/${mp}
. endfor
.endif
+.if ${BLACKHOLE} != '' && ${BLACKHOLE} != 0
+ # ====================================================
+ # net.inet.tcp.blackhole is non-zero. Some http-tests
+ # will appear to hang and then fail. Do not be alarmed.
+ # The socket.test would hang, so it is disabled:
+ ${MV} ${WRKSRC:H}/tests/socket.test ${WRKSRC:H}/tests/socket.test.dis;
+ # ====================================================
+.endif
post-install:
.if exists(${PKGINSTALL})