aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tclX/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2004-04-06 05:18:14 +0800
committermi <mi@FreeBSD.org>2004-04-06 05:18:14 +0800
commit0c800675fd543d0b9cc9dd215cb55c1de0589fc4 (patch)
tree879e0a16249b56824b22218dc3a36d2e127bf492 /lang/tclX/Makefile
parent3b5c261a4867b7362ac72b6a4f7c90d70ed34be5 (diff)
downloadfreebsd-ports-gnome-0c800675fd543d0b9cc9dd215cb55c1de0589fc4.tar.gz
freebsd-ports-gnome-0c800675fd543d0b9cc9dd215cb55c1de0589fc4.tar.zst
freebsd-ports-gnome-0c800675fd543d0b9cc9dd215cb55c1de0589fc4.zip
Default to Tcl-8.4 (and bump up PORTREVISION). Fix some 64-bit related issues.
Some others remain -- not all are fixed in the Tcl itself.
Diffstat (limited to 'lang/tclX/Makefile')
-rw-r--r--lang/tclX/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/tclX/Makefile b/lang/tclX/Makefile
index 12d5540cfc5e..0ccdca431cca 100644
--- a/lang/tclX/Makefile
+++ b/lang/tclX/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tclX
PORTVERSION= 8.3.5
+PORTREVISION= 1
CATEGORIES= lang tcl${TCL_DVER} tk${TCL_DVER}
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=tclx
@@ -23,7 +24,7 @@ PKGNAMESUFFIX= -nox11
LIB_DEPENDS= tk${TCL_DVER}.1:${PORTSDIR}/x11-toolkits/tk${TCL_DVER}
.endif
-TCL_VER?= 8.3
+TCL_VER?= 8.4
TCL_DVER?= ${TCL_VER:S/.//}
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
@@ -33,7 +34,8 @@ CONFIGURE_ARGS= --enable-shared \
--with-help=Help \
--with-tcl="${LOCALBASE}/lib/tcl${TCL_VER}" \
--with-tk="${LOCALBASE}/lib/tk${TCL_VER}"
-PLIST_SUB= TCLX_LONG_VER=${TCL_VER} TCLX_SHORT_VER=${TCL_DVER}
+PLIST_SUB= TCLX_LONG_VER=${PORTVERSION:R} \
+ TCLX_SHORT_VER=${PORTVERSION:R:S/.//}
.ifdef WITHOUT_X11
CONFIGURE_ARGS+=--enable-tk=NO