aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tinycobol
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-30 07:14:29 +0800
committerpav <pav@FreeBSD.org>2004-05-30 07:14:29 +0800
commit2e80c69e336f2f67db367cb111aa025840b59dab (patch)
treedd179157d434ad24b0e7a6155ce4d10d90baeb5c /lang/tinycobol
parent1c39f28646860ebf992732c64e16d020998ac7ee (diff)
downloadfreebsd-ports-gnome-2e80c69e336f2f67db367cb111aa025840b59dab.tar.gz
freebsd-ports-gnome-2e80c69e336f2f67db367cb111aa025840b59dab.tar.zst
freebsd-ports-gnome-2e80c69e336f2f67db367cb111aa025840b59dab.zip
- Update to 0.61 and unbreak
PR: ports/63796 Submitted by: vs Approved by: maintainer timeout (3 months)
Diffstat (limited to 'lang/tinycobol')
-rw-r--r--lang/tinycobol/Makefile26
-rw-r--r--lang/tinycobol/distinfo4
-rw-r--r--lang/tinycobol/files/patch-aa43
-rw-r--r--lang/tinycobol/pkg-plist16
4 files changed, 29 insertions, 60 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
index b7299c97d012..9a17e59c3f08 100644
--- a/lang/tinycobol/Makefile
+++ b/lang/tinycobol/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tinycobol
-PORTVERSION= 0.59
-PORTREVISION= 2
+PORTVERSION= 0.61
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tiny-cobol
@@ -17,31 +16,28 @@ COMMENT= A tiny COBOL compiler for IA32 platforms
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2
+INSTALLS_SHLIB= yes
ONLY_FOR_ARCHS= i386
USE_GETOPT_LONG=yes
HAS_CONFIGURE= yes
USE_BISON= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= "--with-readline"
+CONFIGURE_ARGS= --with-libdb=2
+# --with-readline disabled because of CPP-clash between readline/chardefs.h
+# and htcobol.tab.h:PAGE/RETURN/ALPHABETIC
+#CONFIGURE_ARGS+= --with-readline
CPPFLAGS= -I${LOCALBASE}/include
+CFLAGS= ${CPPFGLAGS}
LDFLAGS= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= htcobol.1 htcobf2f.1 htcobolpp.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-pre-install:
-
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/tinycobol
- ${INSTALL_DATA} ${WRKSRC}/info/*.txt ${PREFIX}/share/doc/tinycobol
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/info/*.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/tinycobol/distinfo b/lang/tinycobol/distinfo
index 26fd05f9afdb..837d4738a0df 100644
--- a/lang/tinycobol/distinfo
+++ b/lang/tinycobol/distinfo
@@ -1,2 +1,2 @@
-MD5 (tinycobol-0.59.tar.gz) = 755d41f049f6530aab7f1b9a393472ed
-SIZE (tinycobol-0.59.tar.gz) = 568473
+MD5 (tinycobol-0.61.tar.gz) = d9b5c00a2407ab8b42689a7d21c62af2
+SIZE (tinycobol-0.61.tar.gz) = 817294
diff --git a/lang/tinycobol/files/patch-aa b/lang/tinycobol/files/patch-aa
index f3c35804582c..cb987fee6cc3 100644
--- a/lang/tinycobol/files/patch-aa
+++ b/lang/tinycobol/files/patch-aa
@@ -1,38 +1,11 @@
---- configure.orig Sun Oct 20 04:37:38 2002
-+++ configure Tue Nov 5 16:23:57 2002
-@@ -952,7 +952,7 @@
-
- ac_ext=c
- ac_cpp='$CPP $CPPFLAGS'
--ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-+ac_compile='$CC -c $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-
-@@ -4070,7 +4070,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-ldb $LIBS"
-+LIBS="-ldb2 $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- #line 4075 "configure"
- #include "confdefs.h"
-@@ -4679,7 +4679,7 @@
- #define USE_DB 1
- EOF
-
-- htg_ld_args_db="-ldb"
-+ htg_ld_args_db="-ldb2"
- fi
-
- if test "${db_version}" = "123" ; then
-@@ -5229,7 +5229,7 @@
- #
-
+--- configure.orig Fri Mar 5 11:33:30 2004
++++ configure Fri Mar 5 11:33:43 2004
+@@ -698,7 +698,7 @@
+ curses_header='ncurses.h'
+ curses_library='ncurses'
LIBS="-L/usr/lib $M_LIBS"
-INCLUDES="-I/usr/include -I../lib -I../"
-+INCLUDES="-I/usr/include -I../lib -I../ -I/usr/local/include"
++INCLUDES="-I/usr/include -I/usr/local/include -I../lib -I../"
- # set default directories
- #
+ # Check for executable suffix
+ # Set include and libraries paths
diff --git a/lang/tinycobol/pkg-plist b/lang/tinycobol/pkg-plist
index 37e1504d4a5b..544fd265bd3c 100644
--- a/lang/tinycobol/pkg-plist
+++ b/lang/tinycobol/pkg-plist
@@ -1,16 +1,16 @@
bin/htcobol
share/htcobol/htcobolrc
-lib/libhtcobol.so.0.59.0
+lib/libhtcobol.so.0.61.0
lib/libhtcobol.so
lib/libhtcobol.so.0
share/htcobol/htcobolpp
share/htcobol/copybooks/screen.cpy
-share/doc/tinycobol/Comments.old.txt
-share/doc/tinycobol/Compiler-Overview.txt
-share/doc/tinycobol/GAS.asm-i386.Info.txt
-share/doc/tinycobol/ProgramHeaders.Info.txt
-share/doc/tinycobol/VarStructure.Info.txt
-share/doc/tinycobol/compiler-design-future.txt
+%%PORTDOCS%%%%DOCSDIR%%/Comments.old.txt
+%%PORTDOCS%%%%DOCSDIR%%/Compiler-Overview.txt
+%%PORTDOCS%%%%DOCSDIR%%/GAS.asm-i386.Info.txt
+%%PORTDOCS%%%%DOCSDIR%%/ProgramHeaders.Info.txt
+%%PORTDOCS%%%%DOCSDIR%%/VarStructure.Info.txt
+%%PORTDOCS%%%%DOCSDIR%%/compiler-design-future.txt
@dirrm share/htcobol/copybooks
-@dirrm share/doc/tinycobol
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/htcobol