aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tolua4/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-11-21 17:32:07 +0800
committeredwin <edwin@FreeBSD.org>2004-11-21 17:32:07 +0800
commit95fe79a1ef9cd4d8244a2ea42dcb6bd48c03fce6 (patch)
tree9b909f19539fd73f6212871867d9ff62206f9379 /lang/tolua4/Makefile
parentfbe46528f227f4b3a2050d9d422daa4a6b6fcf60 (diff)
downloadfreebsd-ports-gnome-95fe79a1ef9cd4d8244a2ea42dcb6bd48c03fce6.tar.gz
freebsd-ports-gnome-95fe79a1ef9cd4d8244a2ea42dcb6bd48c03fce6.tar.zst
freebsd-ports-gnome-95fe79a1ef9cd4d8244a2ea42dcb6bd48c03fce6.zip
toLua is a tool that greatly simplifies the integration of C/C++
code with Lua. Based on a "cleaned" header file, toLua automatically generates the binding code to access C/C++ features from Lua. Using Lua-5.0 API and tag method facilities, the current version automatically maps C/C++ constants, external variables, functions, namespace, classes, and methods to Lua. It also provides facilities to create Lua modules. WWW: http://www.tecgraf.puc-rio.br/~celes/tolua/ Author: Waldemar Celes <celes@tecgraf.puc-rio.br>
Diffstat (limited to 'lang/tolua4/Makefile')
-rw-r--r--lang/tolua4/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/lang/tolua4/Makefile b/lang/tolua4/Makefile
new file mode 100644
index 000000000000..9330f0722101
--- /dev/null
+++ b/lang/tolua4/Makefile
@@ -0,0 +1,30 @@
+#
+# New ports collection makefile for: tolua
+# Date created: 21 November 2004
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tolua4
+PORTVERSION= 4.0a
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/ \
+ http://www.tecgraf.puc-rio.br/~celes/tolua/
+DISTNAME= tolua-4.0a
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= toLua: accessing C/C++ code from Lua
+
+LIB_DEPENDS= lua.4:${PORTSDIR}/lang/lua4
+
+WRKSRC= ${WRKDIR}/tolua
+USE_GMAKE= yes
+CONFLICTS= tolua-5.*
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/tolua ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/include/tolua.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/lib/libtolua.a ${PREFIX}/lib
+
+.include <bsd.port.mk>