aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tolua50/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-11-21 16:32:23 +0800
committeredwin <edwin@FreeBSD.org>2004-11-21 16:32:23 +0800
commit11d6e8ca1f7f24f1b6d750d5a4798bc14cf9db21 (patch)
treeb11083e3e98a97ee2564dfe2f5732fa37cad843e /lang/tolua50/Makefile
parent3d67e0c701263317f856be442330bafaa1e94a26 (diff)
downloadfreebsd-ports-gnome-11d6e8ca1f7f24f1b6d750d5a4798bc14cf9db21.tar.gz
freebsd-ports-gnome-11d6e8ca1f7f24f1b6d750d5a4798bc14cf9db21.tar.zst
freebsd-ports-gnome-11d6e8ca1f7f24f1b6d750d5a4798bc14cf9db21.zip
toLua is a tool that greatly simplifies the integration of C/C++
code with Lua. Based on a "cleaned" header file, toLua automatically generates the binding code to access C/C++ features from Lua. Using Lua-5.0 API and tag method facilities, the current version automatically maps C/C++ constants, external variables, functions, namespace, classes, and methods WWW: http://www.tecgraf.puc-rio.br/~celes/tolua/
Diffstat (limited to 'lang/tolua50/Makefile')
-rw-r--r--lang/tolua50/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/lang/tolua50/Makefile b/lang/tolua50/Makefile
new file mode 100644
index 000000000000..d71e9b2d129b
--- /dev/null
+++ b/lang/tolua50/Makefile
@@ -0,0 +1,29 @@
+#
+# New ports collection makefile for: tolua
+# Date created: 21 November 2004
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tolua
+PORTVERSION= 5.0.1
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/ \
+ http://www.tecgraf.puc-rio.br/~celes/tolua/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= toLua: accessing C/C++ code from Lua
+
+LIB_DEPENDS= lua:${PORTSDIR}/lang/lua
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-5.0
+
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/tolua ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/include/tolua.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/lib/libtolua.a ${PREFIX}/lib
+
+.include <bsd.port.mk>