aboutsummaryrefslogtreecommitdiffstats
path: root/lang/v8-devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-03-27 17:22:54 +0800
committervanilla <vanilla@FreeBSD.org>2014-03-27 17:22:54 +0800
commit798ccfa8b56108f72b006a41d10956e853654ec5 (patch)
tree3e275872db4039ab2828e6343c06ae9cce560aa6 /lang/v8-devel
parent8a1cfe4b54c673d79522afa3aa8148b7ff1711ba (diff)
downloadfreebsd-ports-gnome-798ccfa8b56108f72b006a41d10956e853654ec5.tar.gz
freebsd-ports-gnome-798ccfa8b56108f72b006a41d10956e853654ec5.tar.zst
freebsd-ports-gnome-798ccfa8b56108f72b006a41d10956e853654ec5.zip
1: fix build with clang34.
2: convert to new style of LIB_DEPENDS. 3: switch to tar:xz Submitted by: lev@ [1]
Diffstat (limited to 'lang/v8-devel')
-rw-r--r--lang/v8-devel/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/v8-devel/Makefile b/lang/v8-devel/Makefile
index 3690105651a8..7ebad47c3f40 100644
--- a/lang/v8-devel/Makefile
+++ b/lang/v8-devel/Makefile
@@ -19,9 +19,8 @@ LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
CONFLICTS= v8-3.19.*
-USES= gmake shebangfix compiler
+USES= gmake shebangfix compiler tar:xz
SHEBANG_FILES= ${WRKSRC}/build/gyp/gyp
-USE_XZ= yes
USE_PYTHON= 2
USE_LDCONFIG= yes
ALL_TARGET= native
@@ -38,6 +37,9 @@ CFLAGS+= -Wno-unused-private-field -Wno-unused-variable
.if ${COMPILER_VERSION} >= 33
CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
.endif
+.if ${COMPILER_VERSION} >= 34
+CFLAGS+= -Wno-unused-const-variable
+.endif
.else
MAKE_ARGS+= strictaliasing=off
USE_GCC= any