aboutsummaryrefslogtreecommitdiffstats
path: root/lang/wxbasic
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-22 00:20:23 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-22 00:20:23 +0800
commitc33ba7a93beedb65065750f6fa125277fa1f1b51 (patch)
tree4b05f56b4bd74a7dbee4fca4ad8a61f8aa5e5bfe /lang/wxbasic
parent47ed91c6adc3291426fa5760230286c31b9dc8be (diff)
downloadfreebsd-ports-gnome-c33ba7a93beedb65065750f6fa125277fa1f1b51.tar.gz
freebsd-ports-gnome-c33ba7a93beedb65065750f6fa125277fa1f1b51.tar.zst
freebsd-ports-gnome-c33ba7a93beedb65065750f6fa125277fa1f1b51.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39605 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'lang/wxbasic')
-rw-r--r--lang/wxbasic/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/wxbasic/Makefile b/lang/wxbasic/Makefile
index 4d2174da1272..d97625af8343 100644
--- a/lang/wxbasic/Makefile
+++ b/lang/wxbasic/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk-devel
NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
USE_BISON= yes
USE_GMAKE= yes
MAKEFILE= makefile.unx
@@ -27,7 +28,7 @@ LIBS+= -lglut -lGL -lGLU -lwx_gtk_gl ${PTHREAD_LIBS}
MAKE_ENV= CXXFLAGS="${CXXFLAGS}" LIBS="${LIBS}"
post-patch:
- @${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/core.c
+ @${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/core.c
pre-build:
@(cd ${WRKSRC} ; \