aboutsummaryrefslogtreecommitdiffstats
path: root/lang/yap-devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-11 05:05:48 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-11 05:05:48 +0800
commit654c177185a3746dab6732a09d2c06adeec84ad9 (patch)
treea978b786be0ea19a40ef260885483188072c9578 /lang/yap-devel
parent90af13c4ce615548c96213fb662f0200fc3f68dc (diff)
downloadfreebsd-ports-gnome-654c177185a3746dab6732a09d2c06adeec84ad9.tar.gz
freebsd-ports-gnome-654c177185a3746dab6732a09d2c06adeec84ad9.tar.zst
freebsd-ports-gnome-654c177185a3746dab6732a09d2c06adeec84ad9.zip
lang/yap{,-devel}: use clang and unbreak with gcc5 or later
In file included from ./Solver.C:20: In file included from ./Solver.h:29: ./SolverTypes.h:122:20: error: friend declaration specifying a default argument must be a definition friend Clause* Clause_new(const V& ps, bool learnt = false); ^ ./SolverTypes.h:147:9: error: friend declaration specifying a default argument must be the only declaration Clause* Clause_new(const V& ps, bool learnt) { ^ ./SolverTypes.h:122:20: note: previous declaration is here friend Clause* Clause_new(const V& ps, bool learnt = false); ^ ./Solver.C:123:21: error: no matching function for call to 'Clause_new' Clause* c = Clause_new(ps, false); ^~~~~~~~~~ ./Solver.C:602:29: error: no matching function for call to 'Clause_new' Clause* c = Clause_new(learnt_clause, true); ^~~~~~~~~~ 4 errors generated. PR: 216809 Obtained from: upstream Approved by: portmgr blanket
Diffstat (limited to 'lang/yap-devel')
-rw-r--r--lang/yap-devel/Makefile8
-rw-r--r--lang/yap-devel/files/patch-configure13
-rw-r--r--lang/yap-devel/files/patch-packages_swi-minisat2_C_SolverTypes.h13
3 files changed, 32 insertions, 2 deletions
diff --git a/lang/yap-devel/Makefile b/lang/yap-devel/Makefile
index be1a3fd58123..b97a69c8c07d 100644
--- a/lang/yap-devel/Makefile
+++ b/lang/yap-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= yap
PORTVERSION= 6.3.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang
MASTER_SITES= http://www.dcc.fc.up.pt/~vsc/Yap/
PKGNAMESUFFIX= -devel
@@ -43,13 +43,17 @@ SHEBANG_FILES= packages/http/examples/demo_inetd
SHEBANG_LANG= swipl
swipl_OLD_CMD= /usr/bin/swipl
swipl_CMD= ${LOCALBASE}/bin/swipl # installed by lang/swi-pl
-USE_GCC= any
DOCSDIR= ${PREFIX}/share/doc/Yap
DATADIR= ${PREFIX}/share/Yap
.include <bsd.port.options.mk>
+.if ${ARCH} == i386
+# H/absmi.h:77:23: error: global register variables are not supported
+USES+= compiler:gcc-c++11-lib
+.endif
+
post-build:
.if empty(PORT_OPTIONS:MDOCS)
# prevent the installation of docs files
diff --git a/lang/yap-devel/files/patch-configure b/lang/yap-devel/files/patch-configure
new file mode 100644
index 000000000000..baf8b055e05c
--- /dev/null
+++ b/lang/yap-devel/files/patch-configure
@@ -0,0 +1,13 @@
+https://sourceforge.net/p/yap/yap-6.3/ci/da61f1c31fed
+
+--- configure.orig 2013-01-19 11:48:08 UTC
++++ configure
+@@ -5169,7 +5169,7 @@ then
+ C_PARSER_FLAGS="-O3 -Wall -Wstrict-prototypes -Wmissing-prototypes $CFLAGS"
+ CFLAGS="-O3 -fomit-frame-pointer -Wall -Wstrict-prototypes -Wmissing-prototypes $CFLAGS"
+ case "`$CC --version < /dev/null`" in
+- *3.4*) CFLAGS="-fno-gcse -fno-crossjumping $CFLAGS" ;;
++ gcc-3.4*) CFLAGS="-fno-gcse -fno-crossjumping $CFLAGS" ;;
+ esac
+ case "$target_cpu" in
+ i*86*)
diff --git a/lang/yap-devel/files/patch-packages_swi-minisat2_C_SolverTypes.h b/lang/yap-devel/files/patch-packages_swi-minisat2_C_SolverTypes.h
new file mode 100644
index 000000000000..6568e2788511
--- /dev/null
+++ b/lang/yap-devel/files/patch-packages_swi-minisat2_C_SolverTypes.h
@@ -0,0 +1,13 @@
+https://sourceforge.net/p/yap/yap-6.3/ci/6d2e2597b183
+
+--- packages/swi-minisat2/C/SolverTypes.h.orig 2012-06-29 21:30:38 UTC
++++ packages/swi-minisat2/C/SolverTypes.h
+@@ -119,7 +119,7 @@ public:
+
+ // -- use this function instead:
+ template<class V>
+- friend Clause* Clause_new(const V& ps, bool learnt = false);
++ friend Clause* Clause_new(const V& ps, bool learnt);
+
+ int size () const { return size_etc >> 3; }
+ void shrink (int i) { assert(i <= size()); size_etc = (((size_etc >> 3) - i) << 3) | (size_etc & 7); }