aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-06-09 20:18:26 +0800
committerolgeni <olgeni@FreeBSD.org>2015-06-09 20:18:26 +0800
commit08b02e44feba771bdef43cf4e17d04fe94737e59 (patch)
tree1df60e838c33e669e154e4f451acd9d780f0d051 /lang
parent86c06c3ef4c0e2fab6b54045038e89e23b333dd0 (diff)
downloadfreebsd-ports-gnome-08b02e44feba771bdef43cf4e17d04fe94737e59.tar.gz
freebsd-ports-gnome-08b02e44feba771bdef43cf4e17d04fe94737e59.tar.zst
freebsd-ports-gnome-08b02e44feba771bdef43cf4e17d04fe94737e59.zip
Add hotfix for unhandled cipher algorithms.
Obtained from: Ingela Andin (ingela.andin@gmail.com) on erlang-questions
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime17/Makefile1
-rw-r--r--lang/erlang-runtime17/files/patch-lib_ssl_src_ssl__cipher.erl22
2 files changed, 23 insertions, 0 deletions
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index e0c843d5a254..4a73383710a6 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -3,6 +3,7 @@
PORTNAME= erlang
PORTVERSION= 17.5.6
+PORTREVISION= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
diff --git a/lang/erlang-runtime17/files/patch-lib_ssl_src_ssl__cipher.erl b/lang/erlang-runtime17/files/patch-lib_ssl_src_ssl__cipher.erl
new file mode 100644
index 000000000000..efa6734a3e19
--- /dev/null
+++ b/lang/erlang-runtime17/files/patch-lib_ssl_src_ssl__cipher.erl
@@ -0,0 +1,22 @@
+--- lib/ssl/src/ssl_cipher.erl.orig 2015-03-31 12:32:52 UTC
++++ lib/ssl/src/ssl_cipher.erl
+@@ -1209,7 +1209,8 @@ hash_algorithm(?SHA) -> sha;
+ hash_algorithm(?SHA224) -> sha224;
+ hash_algorithm(?SHA256) -> sha256;
+ hash_algorithm(?SHA384) -> sha384;
+-hash_algorithm(?SHA512) -> sha512.
++hash_algorithm(?SHA512) -> sha512;
++hash_algorithm(Other) when is_integer(Other) andalso ((Other >= 224) and (Other =< 255)) -> Other.
+
+ sign_algorithm(anon) -> ?ANON;
+ sign_algorithm(rsa) -> ?RSA;
+@@ -1218,7 +1219,8 @@ sign_algorithm(ecdsa) -> ?ECDSA;
+ sign_algorithm(?ANON) -> anon;
+ sign_algorithm(?RSA) -> rsa;
+ sign_algorithm(?DSA) -> dsa;
+-sign_algorithm(?ECDSA) -> ecdsa.
++sign_algorithm(?ECDSA) -> ecdsa;
++sign_algorithm(Other) when is_integer(Other) andalso ((Other >= 224) and (Other =< 255)) -> Other.
+
+ hash_size(null) ->
+ 0;
etions'>-4/+4 * - Update to 1.53itetcu2010-04-032-5/+5 * - Update to 1.52pgollucci2010-01-122-4/+4 * - update to 1.51leeym2009-12-072-4/+4 * - Update to 1.50wen2009-11-224-7/+14 * Update to 1.40.tobez2009-08-172-4/+4 * Update to 1.39.tobez2009-08-142-4/+4 * - lang/perl5.6 is dead, remove PERL_LEVEL/PERL_VERSION < 500801 checkspgollucci2009-07-231-7/+1 * - update to 1.38leeym2009-05-292-4/+4 * Reassign my p5-* ports to perl@ so more than one personerwin2009-01-301-1/+1 * Update to 1.37erwin2008-06-302-11/+6 * - Take advantage of CPAN macro from bsd.sites.mk, change ${MASTER_SITE_PERL_C...araujo2008-04-171-2/+1 * Update to 1.36erwin2008-04-042-4/+4 * - Add SHA256pav2005-11-271-0/+1 * search.cpan.org redirect reduction canonicalization project, pass 1:fenner2005-09-221-1/+1 * Update to 1.35 (1.34 disappeared from CPAN & mirrors).tobez2004-12-012-3/+3 * Update to 1.34erwin2004-10-142-3/+3 * Update to 1.31erwin2004-06-082-3/+3 * Add size data, approved by maintainers.trevor2004-03-191-0/+1 * Update to 1.30erwin2004-01-152-2/+2 * Update to 1.29erwin2004-01-023-2/+6 * Update to 1.28erwin2003-12-042-2/+2 * utilize SITE_PERLijliao2003-10-241-1/+0 * Update to 1.27erwin2003-10-142-2/+2 * - Update to 1.25erwin2003-08-303-52/+54 * Change to my FreeBSD.org addresserwin2003-06-131-1/+1 * maintainer-update WWW for cpan from /search?dist=module to /dist/moduleedwin2003-04-131-1/+1 * De-pkg-comment.knu2003-02-212-1/+1 * Conditionalise several dependencies on PERL_LEVEL to make those ports moresobomax2003-02-211-3/+8 * Update to 1.23.petef2003-01-063-2/+3 * Update to version 1.22kevlo2002-09-033-2/+6 * Update to 1.21pat2002-08-072-2/+2 * - update to 1.20ijliao2002-07-214-26/+15 * Upgrade to 1.19ache2002-05-192-3/+3 * Upgrade to 1.18ache2002-04-293-2/+3 * Upgrade to 1.17ache2001-11-262-2/+2 * Upgrade to 1.15.vanilla2001-07-232-2/+2 * Upgrade to latest version:vanilla2001-05-102-10/+10 * Upgradevanilla2001-03-012-2/+2 * Remove do-configure section, use PERL_CONFIGURE now.vanilla2001-03-011-5/+2 * Upgrade to 1.10.vanilla2001-01-262-2/+2 * Massive style enforcement - use ^I instead of spaces for variables identation.sobomax2001-01-171-8/+8 * Upgrade to 1.09ache2000-08-193-6/+6 * Updatevanilla2000-07-222-7/+6 * Upgradevanilla2000-04-233-25/+27 * Update with the new PORTNAME/PORTVERSION variablescpiazza2000-04-101-3/+3 * upgrade to 1.04ache2000-01-082-3/+3 * Add depends on p5-MIME-Base64ache1999-09-101-0/+2 * FreeBSD.ORG -> FreeBSD.orgmharo1999-08-311-1/+1 * $Id$ -> $FreeBSD$peter1999-08-301-1/+1 * upgrade to 1.03ache1999-08-022-4/+4 * Commit #3/4 to enforce caps, no period.hoek1999-06-271-1/+1