aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-23 22:20:25 +0800
committerbapt <bapt@FreeBSD.org>2013-04-23 22:20:25 +0800
commit135776951ec27858cec633271bc65e3e49745f01 (patch)
tree87b239f8431cee200969f89da8739806496b7dad /lang
parent403f9e420456633793408637949b5119d9c957d8 (diff)
downloadfreebsd-ports-gnome-135776951ec27858cec633271bc65e3e49745f01.tar.gz
freebsd-ports-gnome-135776951ec27858cec633271bc65e3e49745f01.tar.zst
freebsd-ports-gnome-135776951ec27858cec633271bc65e3e49745f01.zip
Finish converting the whole ports tree to USES=pkgconfig
Diffstat (limited to 'lang')
-rw-r--r--lang/embryo/Makefile3
-rw-r--r--lang/fsharp/Makefile2
-rw-r--r--lang/gjs/Makefile2
-rw-r--r--lang/gnustep-base/Makefile2
-rw-r--r--lang/lua/Makefile2
-rw-r--r--lang/vala/Makefile3
6 files changed, 6 insertions, 8 deletions
diff --git a/lang/embryo/Makefile b/lang/embryo/Makefile
index 643d0f7112d6..692b0e83eb0d 100644
--- a/lang/embryo/Makefile
+++ b/lang/embryo/Makefile
@@ -16,9 +16,8 @@ LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= pathfix
+USES= pathfix pkgconfig
USE_EFL= eina libtool_hack librt_hack
-USE_PKGCONFIG= yes
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/lang/fsharp/Makefile b/lang/fsharp/Makefile
index 3f8f0a402047..d685bfc67743 100644
--- a/lang/fsharp/Makefile
+++ b/lang/fsharp/Makefile
@@ -16,9 +16,9 @@ LICENSE= AL2
BUILD_DEPENDS= mono>=3.0:${PORTSDIR}/lang/mono
RUN_DEPENDS= mono>=3.0:${PORTSDIR}/lang/mono
+USES= pkgconfig
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf
-USE_PKGCONFIG= build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/lang/gjs/Makefile b/lang/gjs/Makefile
index 48b14a2e6f8b..4bdc5b23d62a 100644
--- a/lang/gjs/Makefile
+++ b/lang/gjs/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_PYTHON_BUILD=yes
USE_AUTOTOOLS= libtool
USE_GNOME= gnomeprefix gnomehack intlhack glib20 ltverhack
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 18c44389e7f7..7d40861ed439 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -31,7 +31,7 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
USE_ICONV= yes
-USE_PKGCONFIG= yes
+USES= pkgconfig
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
diff --git a/lang/lua/Makefile b/lang/lua/Makefile
index a92bf70dcd68..709eaeb8862e 100644
--- a/lang/lua/Makefile
+++ b/lang/lua/Makefile
@@ -20,7 +20,7 @@ PATCH_WRKSRC= ${WRKSRC}/src
USE_LUA= 5.1
LUA_COMPS= # only define variables
ALL_TARGET= freebsd
-USE_PKGCONFIG= yes
+USES= pkgconfig
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
MAKE_ENV= LUA_SONAME="liblua-${LUA_VER}.so.${LUA_VER_SH}"
diff --git a/lang/vala/Makefile b/lang/vala/Makefile
index 05fcf6ea6f76..907ed8f4052c 100644
--- a/lang/vala/Makefile
+++ b/lang/vala/Makefile
@@ -12,11 +12,10 @@ COMMENT= Programming language and compiler that converts Vala code into C code
LICENSE= LGPL21
-USES= bison pathfix
+USES= bison pathfix pkgconfig
USE_XZ= yes
USE_GNOME= glib20 gnomeprefix libxslt
USE_GMAKE= yes
-USE_PKGCONFIG= build
GNU_CONFIGURE= yes
USE_GETTEXT= yes
CPPFLAGS+= -I${LOCALBASE}/include