aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-17 21:14:27 +0800
committerpav <pav@FreeBSD.org>2003-12-17 21:14:27 +0800
commit27edcb0ac37366d7c6950e22c51399b4d36962d3 (patch)
tree2b6feef198c32aa3e04d5873488ac03e23103f28 /lang
parentebc5d441095cba74593f5f3448e7e07104f59ce0 (diff)
downloadfreebsd-ports-gnome-27edcb0ac37366d7c6950e22c51399b4d36962d3.tar.gz
freebsd-ports-gnome-27edcb0ac37366d7c6950e22c51399b4d36962d3.tar.zst
freebsd-ports-gnome-27edcb0ac37366d7c6950e22c51399b4d36962d3.zip
Add slib-gauche, a port that installs slib into gauche catalog.
PR: ports/60282 Submitted by: Kimura Fuyuki <fuyuki@nigredo.org>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/slib-gauche/Makefile28
-rw-r--r--lang/slib-gauche/pkg-descr4
-rw-r--r--lang/slib-gauche/pkg-plist2
4 files changed, 35 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 12cd6ce3f9af..8e4f299c9a5b 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -216,6 +216,7 @@
SUBDIR += siod
SUBDIR += sisc
SUBDIR += slib
+ SUBDIR += slib-gauche
SUBDIR += slib-guile
SUBDIR += slisp
SUBDIR += smalltalk
diff --git a/lang/slib-gauche/Makefile b/lang/slib-gauche/Makefile
new file mode 100644
index 000000000000..e141492f45a2
--- /dev/null
+++ b/lang/slib-gauche/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: SLIB for Gauche
+# Date created: 27 October 2003
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= slib
+PORTVERSION= 3a1 # Keep this in sync with devel/slib
+CATEGORIES= lang scheme
+MASTER_SITES= # empty
+PKGNAMESUFFIX= -gauche
+DISTFILES= # empty
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= SLIB installation for Gauche
+
+BUILD_DEPENDS= ${LOCALBASE}/share/slib/require.scm:${PORTSDIR}/lang/slib \
+ gosh:${PORTSDIR}/lang/gauche
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+PLIST_SUB= VERSION="`gauche-config -V`"
+
+do-install:
+ ${LOCALBASE}/bin/gosh -uslib -E"require 'new-catalog" -Eexit
+
+.include <bsd.port.mk>
diff --git a/lang/slib-gauche/pkg-descr b/lang/slib-gauche/pkg-descr
new file mode 100644
index 000000000000..4501db7da222
--- /dev/null
+++ b/lang/slib-gauche/pkg-descr
@@ -0,0 +1,4 @@
+To use the features offered by the SLIB library, add the following
+construct to your programs:
+
+ (use slib)
diff --git a/lang/slib-gauche/pkg-plist b/lang/slib-gauche/pkg-plist
new file mode 100644
index 000000000000..8d3c6993f538
--- /dev/null
+++ b/lang/slib-gauche/pkg-plist
@@ -0,0 +1,2 @@
+@exec %%LOCALBASE%%/bin/gosh -uslib -E"require 'new-catalog" -Eexit
+@unexec rm -f %%LOCALBASE%%/share/gauche/%%VERSION%%/lib/slibcat