aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-02 22:33:37 +0800
committermiwi <miwi@FreeBSD.org>2014-02-02 22:33:37 +0800
commit2cbd09f912f78415d4c42c70a8c74fddd2f016d6 (patch)
tree149ccf6e15957795fd2e787c27cc0cfc8cefd0bd /lang
parent306667c1f8b69751d430df6eaa3672b32817341a (diff)
downloadfreebsd-ports-gnome-2cbd09f912f78415d4c42c70a8c74fddd2f016d6.tar.gz
freebsd-ports-gnome-2cbd09f912f78415d4c42c70a8c74fddd2f016d6.tar.zst
freebsd-ports-gnome-2cbd09f912f78415d4c42c70a8c74fddd2f016d6.zip
- Stage support
- Convert few ports to USES
Diffstat (limited to 'lang')
-rw-r--r--lang/open-cobol/Makefile3
-rw-r--r--lang/phc/Makefile3
-rw-r--r--lang/rexx-wrapper/Makefile1
3 files changed, 2 insertions, 5 deletions
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index 64210ad6e8c6..95f698e09a3d 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -12,7 +12,7 @@ COMMENT= An open-source COBOL compiler
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
USE_BDB= yes
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
@@ -21,7 +21,6 @@ INFO= open-cobol
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/lang/phc/Makefile b/lang/phc/Makefile
index b52e03c40d30..033342e78569 100644
--- a/lang/phc/Makefile
+++ b/lang/phc/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.phpcompiler.org/src/archive/
MAINTAINER= eg@fbsd.lt
COMMENT= A compiler for the PHP language
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CFLAGS+= -fgnu89-inline
@@ -19,5 +19,4 @@ post-patch: .SILENT
${REINPLACE_CMD} 's/insert/this->&/' \
${WRKSRC}/include/phc/lib/List.h
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/lang/rexx-wrapper/Makefile b/lang/rexx-wrapper/Makefile
index 2d7af1d5a5c4..db93e11e3a6e 100644
--- a/lang/rexx-wrapper/Makefile
+++ b/lang/rexx-wrapper/Makefile
@@ -26,5 +26,4 @@ post-patch: .SILENT
${WRKSRC}/rexxwrap.cmd
@${REINPLACE_CMD} 's/-compiler=$$(CC/&:T/' ${WRKSRC}/Makefile.in
-NO_STAGE= yes
.include <bsd.port.mk>