aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-09-14 00:39:47 +0800
committershaun <shaun@FreeBSD.org>2006-09-14 00:39:47 +0800
commit2db0948dcc7a1fcc7b65eb9c2df3077d839a6ef5 (patch)
tree3fcb7a24bac89ce34fd89aea1b9129540b155fde /lang
parent98ebe83b6e48df75a243c115e1afbf154747b34d (diff)
downloadfreebsd-ports-gnome-2db0948dcc7a1fcc7b65eb9c2df3077d839a6ef5.tar.gz
freebsd-ports-gnome-2db0948dcc7a1fcc7b65eb9c2df3077d839a6ef5.tar.zst
freebsd-ports-gnome-2db0948dcc7a1fcc7b65eb9c2df3077d839a6ef5.zip
Fix build/install on 4.x by using gmake+gunzip.
PR: ports/103216 Submitted by: Stanislav Sedov <ssedov@mbsd.msk.ru>
Diffstat (limited to 'lang')
-rw-r--r--lang/ocaml-camlidl/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/ocaml-camlidl/Makefile b/lang/ocaml-camlidl/Makefile
index 898d973b0cc6..f8e03e11cc9f 100644
--- a/lang/ocaml-camlidl/Makefile
+++ b/lang/ocaml-camlidl/Makefile
@@ -26,6 +26,10 @@ DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+.if ${OSVERSION} < 500000
+USE_GMAKE= yes
+.endif
+
post-extract:
@${REINPLACE_CMD} -e "s,^\(OCAMLLIB=\).*,\1${PREFIX}/lib/ocaml,g" \
-e "s,^\(BINDIR=\).*,\1${PREFIX}/bin,g" \
@@ -51,8 +55,8 @@ pre-install:
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${TAR} -C ${DOCSDIR} -xf \
- ${_DISTDIR}/${PORTNAME}-${PORTVERSION}.doc.html.tar.gz
+ ${GZCAT} ${_DISTDIR}/${PORTNAME}-${PORTVERSION}.doc.html.tar.gz \
+ | ${TAR} -C ${DOCSDIR} -xf -
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
${FIND} ${DOCSDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
.endif