aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-09-06 23:10:18 +0800
committeradamw <adamw@FreeBSD.org>2014-09-06 23:10:18 +0800
commit34c0d3272892852db61bfde602692bf10613be46 (patch)
tree98c8ae7941e333b9ecc77364b8e5fcdcaf2af5c8 /lang
parente9899c633894b7f4c36956819dbbdb6b14802d7c (diff)
downloadfreebsd-ports-gnome-34c0d3272892852db61bfde602692bf10613be46.tar.gz
freebsd-ports-gnome-34c0d3272892852db61bfde602692bf10613be46.tar.zst
freebsd-ports-gnome-34c0d3272892852db61bfde602692bf10613be46.zip
Fix build by removing texlive from USE_TEX.
While here, just add install_docs to INSTALL_TARGET rather than calling a separate ${MAKE} without MAKE_ENV or MAKE_ARGS.
Diffstat (limited to 'lang')
-rw-r--r--lang/yap-devel/Makefile10
-rw-r--r--lang/yap/Makefile10
2 files changed, 6 insertions, 14 deletions
diff --git a/lang/yap-devel/Makefile b/lang/yap-devel/Makefile
index 0d2eab77b72d..02c7d4563346 100644
--- a/lang/yap-devel/Makefile
+++ b/lang/yap-devel/Makefile
@@ -20,9 +20,10 @@ OPTIONS_DEFINE= DOCS MYDDAS
OPTIONS_SUB= yes
MYDDAS_DESC= Enable MySQL support
-DOCS_USE= TEX=formats:build,dvipsk:build,texlive
+DOCS_USE= TEX=formats:build,dvipsk:build
DOCS_BUILD_DEPENDS= ${LOCALBASE}/bin/texi2html:${PORTSDIR}/textproc/texi2html \
${LOCALBASE}/bin/texi2pdf:${PORTSDIR}/print/texinfo
+DOCS_INSTALL_TARGET= install install_doc
MYDDAS_LIB_DEPENDS= libiodbc.so:${PORTSDIR}/databases/libiodbc
MYDDAS_CONFIGURE_ENABLE= myddas myddas-top-level
@@ -32,7 +33,7 @@ STRIP= #none
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-max-performance --disable-clpbn-bp
-USES= gmake
+USES= gmake
USE_GCC= any
EXTRACT_CMD= ${GZIP_CMD}
@@ -50,9 +51,4 @@ post-build:
${REINPLACE_CMD} -e '758,761d' ${WRKSRC}/Makefile
.endif
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- (cd ${WRKSRC} ; ${MAKE} DESTDIR=${STAGEDIR} install_docs)
-.endif
-
.include <bsd.port.mk>
diff --git a/lang/yap/Makefile b/lang/yap/Makefile
index ed376f762b46..ba3e2550df98 100644
--- a/lang/yap/Makefile
+++ b/lang/yap/Makefile
@@ -15,14 +15,15 @@ CONFLICTS= yap-6.3.*
OPTIONS_DEFINE= DOCS
-DOCS_USE= TEX=formats:build,dvipsk:build,texlive
+DOCS_USE= TEX=formats:build,dvipsk:build
DOCS_BUILD_DEPENDS= ${LOCALBASE}/bin/texi2html:${PORTSDIR}/textproc/texi2html \
${LOCALBASE}/bin/texi2pdf:${PORTSDIR}/print/texinfo
+DOCS_INSTALL_TARGET= install install_docs
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-max-performance
-USES= gmake
+USES= gmake
USE_GCC= any
DOCSDIR= ${PREFIX}/share/doc/Yap
@@ -36,9 +37,4 @@ post-build:
${REINPLACE_CMD} -e '559,562d' ${WRKSRC}/Makefile
.endif
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- (cd ${WRKSRC} ; ${MAKE} DESTDIR=${STAGEDIR} install_docs)
-.endif
-
.include <bsd.port.mk>