aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-12-25 05:22:21 +0800
committerkwm <kwm@FreeBSD.org>2013-12-25 05:22:21 +0800
commit3602daba968a0e16ff8817cb961f23cd54730acc (patch)
tree93506aaee5230ee46b75930c4b3a6b8e0f243d74 /lang
parentb6e03796b2af561162757d9125b17f9d15197d64 (diff)
downloadfreebsd-ports-gnome-3602daba968a0e16ff8817cb961f23cd54730acc.tar.gz
freebsd-ports-gnome-3602daba968a0e16ff8817cb961f23cd54730acc.tar.zst
freebsd-ports-gnome-3602daba968a0e16ff8817cb961f23cd54730acc.zip
Update freetype to 2.5.2.
Remove patch to add -I/usr/local/include in freetype-config --cflags. If ports need extra headers they should look for them, and not get them via a side-effect. Freetype had a header resuffle in 2.5.1, patch ports to use the new header style. Thanks go to bdrewery for the two exp-runs and rakuco for helping me with some troublesome cmake ports. PR: ports/184587
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile1
-rw-r--r--lang/php52/Makefile1
-rw-r--r--lang/php53/Makefile1
-rw-r--r--lang/php55/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 6696d22f30a0..a33efdc27251 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -169,6 +169,7 @@ CONFIGURE_ARGS+=--disable-ipv6
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+# @${REINPLACE_CMD} -e 's|freetype/||g' ${WRKSRC}/config.m4
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PORT_OPTIONS:MFPM}
@${REINPLACE_CMD} -e "s|^;\(pid\)|\1|;s|^;\(pm\.[a-z_]*_servers\)|\1|" \
diff --git a/lang/php52/Makefile b/lang/php52/Makefile
index e6576f048e90..0bb50d0d4710 100644
--- a/lang/php52/Makefile
+++ b/lang/php52/Makefile
@@ -194,6 +194,7 @@ CONFIGURE_ARGS+=--disable-ipv6
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} -e 's|freetype/||g' ${WRKSRC}/configure
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PORT_OPTIONS:MFPM} && ${PORT_OPTIONS:MCGI}
@${REINPLACE_CMD} -e 's,BUILD_CGI=\"\\$$\(.*\)\\$$(EXTRA_LIBS),BUILD_CGI=\"\\$$\1\\$$(EXTRA_LIBS) \\$$(SAPI_EXTRA_LIBS),g' \
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 0dd20a33bc85..71223cf63818 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -154,6 +154,7 @@ CONFIGURE_ARGS+=--disable-ipv6
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} -e 's|freetype/||g' ${WRKSRC}/configure
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PORT_OPTIONS:MFPM}
@${REINPLACE_CMD} -e "s|^;\(pid\)|\1|;s|^;\(pm\.[a-z_]*_servers\)|\1|" \
diff --git a/lang/php55/Makefile b/lang/php55/Makefile
index 447915272eb0..f28defd6b408 100644
--- a/lang/php55/Makefile
+++ b/lang/php55/Makefile
@@ -169,6 +169,7 @@ CONFIGURE_ARGS+=--disable-ipv6
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} -e 's|freetype/||g' ${WRKSRC}/configure
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PORT_OPTIONS:MFPM}
@${REINPLACE_CMD} -e "s|^;\(pid\)|\1|;s|^;\(pm\.[a-z_]*_servers\)|\1|" \